misa0231as0231
18.10.2020 04:03

Составить программу, позволяющую определить, есть ли среди цифр задорного целого трехзначного числа х четные?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
АляК1
26.07.2020 15:59
Var
  n,d1,d10,d100:integer;
begin
  Write('Введите натуральное трехзначное число: '); Read(n);
  d1:=n mod 10; d100:=n div 100;
  d10:=(n div 10) mod 10;
  if (d1 mod 2 = 0) or (d10 mod 2=0) or (d100 mod 2=0)
  then Writeln('Есть четная цифра')
  else Writeln('Нет четных цифр')
end.
0,0(0 оценок)
Ответ:
bogdanzdebskiy
26.07.2020 15:59
Var
x,ed,des,sot:integer;
Begin
Readln(x);
ed:=x mod 10;
des:=x div 10 mod 10;
sot:=x div 100 mod 10;
x:=0;
if sot mod 10=1 then x:=x+0 else x:=x+1;
if des mod 10=1 then x:=x+0 else x:=x+1;
if ed   mod 10=1 then x:=x+0 else x:=x+1;
if x>0 then writeln('Есть') else writeln('Нет');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота