tanshka
23.06.2021 06:58

дан массив из 17 целых чисел заполненый случайными числами из интервала -7 23 выведите этот массив в строкк и найдите количество нечетнвх положительных элементов массива которые меньше 7 pascal abc.net​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
RealPacani
05.10.2022 18:31
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(5,6,-30,30);
  a.Println(4); Writeln(4*a.ColCount*'-');
  if a.ElementsByRow.Any(t->t=0) then Writeln('Есть нулевые элементы')
  else Writeln('Нет нулевых элементов')
end.

Пример
*** Исходная матрица ***
  16  -8 -16   6  24  -9
   1  -9  26  30   0   5
   7  23  10   3 -15  -4
   8  18  -3 -14 -23  18
  -6  27  -1  20  18 -25

Есть нулевые элементы
0,0(0 оценок)
Ответ:
лиза2698
24.08.2021 19:42
// Программа  и скриншот результата ее работы - в приложениях

var m,n:integer;

// Наибольший общий делитель
function GCD(a,b:integer):integer;
var   x,y:integer;
begin
  x:=a;
  y:=b;
  while x<>y do
    if x>y
    then x:=x-y
    else y:=y-x;

  GCD:=x;
end;

// Наименьшее общее кратное
function SCM(a,b:integer):integer;
begin
  SCM := a*b div GCD(a,b);
end;

begin
  writeln('Введите два целых числа m, n: ');
  readln(m, n);
 
  writeln('Наименьшее общее кратное ',
          m,' и ', n, ' = ', SCM(m,n) );
end.

Напишите программу для нахождения нок для n чисел (pascal)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота