лерчик1253
19.02.2020 15:16

Требуется написать программу (матрицу) в Паскаль по примеру чтобы на выходе было что на фото 2


Требуется написать программу (матрицу) в Паскаль по примеру чтобы на выходе было что на фото 2
Требуется написать программу (матрицу) в Паскаль по примеру чтобы на выходе было что на фото 2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
honeybeyker
11.08.2022 14:30

(см. объяснение)

Объяснение:

<!DOCTYPE html>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>

<meta name="keywords" content=""/>

<meta name="description" content=""/>

<title>Мой Сайт</title>

<style type="text/css">

* {margin: 0; padding: 0; }

h1{ margin-top: 55px; color: #; text-shadow: 2px 3px 1px #000000; }

h2 { color: #C7C7C7; }

header { font: 30px verdana; color: #; text-shadow: 2px 3px 2px #000000; position: fixed; left: 0; top: 0; width: 100%; height: 56px; background-color: salmon;}

header > a { color: blue; }

header > a:hover { color: skyblue; }

p { margin: 0 auto; width: 800px; height: 500px; font: 20px serif; text-indent: 20px; border-radius: 25px; border: 3px solid black; background-color: #F0F0F0; }

footer { width: 100%; font: 15px impact; height: 70px; background-color: #A3A3A3; }

</style>

</head>

<body bgcolor="salmon1">

<header>Лучший блог! <a href="index.html">Главная</a> <a href="#">Контакты</a> <a href="#">Обо мне</a></header>

<center>

<h1>Мой блог</h1>

<h2>Ищешь интересные и уникальные истории? Тебе сюда!</h2>

</center>

<hr/>

<h3>История о том, как я задал этот вопрос на и как мне ответил MrSolution</h3>

<p>

Первый абзац моей истории...

</p>

<p>

Второй абзац моей истории...

</p>

<p>

Третий абзац моей истории...

</p>

<footer>Мой самый лучший блог.<br/>Моя почта: [email protected]<br/>Мой телефон: <телефон><br/>Хочешь поделиться своей историей? Пиши мне на почту!</footer>

</body>

0,0(0 оценок)
Ответ:
мик271
23.05.2020 12:21

n = int(input()) # получаем кол-во продуктов и записываем в n

a = {} # библиотека для цен

c = {} # библиотека для кол-во продукта

l = [] # массив для всех проданных продуктов

for i1 in range(n): # цикл для заполнения всех массивов

   b = [] # массив b для отделения цены о названия продукта

   b.append(input().split()) # записываем продукт и его цену в массив b

   k = int(b[0][len(b[0])-1]) # записываем в k цену продукта

   v = ''

   for i in range(len(b[0])-1): # при цикла объединяем название в                одну строчку и записываем в v

       v = v + str(b[0][i]) + ' '

   l.append(v) # добавляем название в массив l

   a[v] = k # добавляем цену и продукт в библиотеку a

   c[v] = 0 # добавляем продукт в библиотеку b

for i in range(len(l)): # записываем при цикла кол-во каждого продукта

   c[l[i]] = c[l[i]]+1

print(len(c)) # выводим кол-во продуктов, которые были проданы

for i in a: # при цикла выводим продукт и сколько за него в итоге заплатили

   print(str(i)+str(a[i]*c[i]))

Объяснение

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота