yannashipunova
01.03.2021 23:05

Написать программу, которая находит площадь треугольника по формуле. С использованием делегатов

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vgjfgadg
30.08.2020 11:55

using System;

namespace kp9p_pr_10_zad_6

{

   class Program

   {

       delegate void Square(double a1, double b1, double alfa1);

       static void Main(string[] args)

       {

           double a, b; // переменные для сторон a и b  

           double alpha; // переменная для угла альфа  

           Console.WriteLine("Введите значения треугольника:\n ");

           Console.Write("a: ");

           a = double.Parse(Console.ReadLine());   // ввод стороны a  

           Console.Write("b: ");

           b = double.Parse(Console.ReadLine()); // ввод стороны b  

           Console.Write("Угол альфа: ");

           alpha = double.Parse(Console.ReadLine()); // ввод угла альфа  

           sq(a, b, alpha);  

           static void sq(double a1, double b1, double alpha1) // функция sq расчета и вывода площади  

           {

               Console.WriteLine("\nПлощадь: {0}", (a1 * b1 * Math.Sin(alpha1)) / 2); // вывод и расчет площади  

           }

       }

   }

}  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота