tatybat
04.09.2022 16:43

Информатика ! На python Даны две дроби A/B и С/D (A, B, C, D- натуральные числа) составить программу умножения дроби на дробь. ответ должен быть несократимой дробью. использовать подпрограмму алгоритма Евклида для определения НОД​


Информатика ! На python Даны две дроби A/B и С/D (A, B, C, D- натуральные числа) составить программу

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1) один символ (например буква) = 1 байт. 1 байт = 8 бит (или по другому - 8 разрядов). Некоторые символы, например иероглифы не умещаются в 1 байт потому что их много, поэтому для них используют не один байт, а больше. Если для символа нужно больше 8 бит, то прибавляют не недостающее число битов, а удваивают число байт. Поэтому буквы (символы) или 8-ми разрядные (1 байт), или 16-ти разрядные (2 байта), или 32-х разрядные (4 байта).
2) МАМА - это 4 обычных символа, или 4 байта (32 бита).
3) один байт, или 8 бит.
4) 15 байт - количество всех букв + пробелы + точка. Или 120 бит.
5) 21 байт, или 168 бит (все буквы + пробел + точка).
6) 7 букв = 7 байт.
7) 20 х 40 = 800 символов/страница. 2 страницы = 1600 символов. 1600 символов = 1600 байт, или 1600 х 8 = 12800 бит.
8) 20 байт.
9) большой латинской "ай" - "I".
10) латинская буква "N".
11) маленькая латинская "ай" - "i". Из формулы Хартли N=2^{i}
0,0(0 оценок)
Ответ:
verarusu02
06.05.2023 07:22
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var a:array[1..20] of integer;
  Randomize;
  for var i:=1 to 20 do a[i]:=Random(-50,50); a.Println;
  var b:=Range(2,20,2).Select(i->a[i]);
  Writeln('Элементы с четными индексами по возрастанию');
  b.Sorted.Println;
  Writeln('Элементы с четными индексами по убыванию');
  b.SortedDescending.Println;
end.

Тестовое решение:
-15 46 -34 -3 43 16 -17 -28 -19 12 -28 -11 48 -12 -1 33 -37 9 6 -40
Элементы с четными индексами по возрастанию
-40 -28 -12 -11 -3 9 12 16 33 46
Элементы с четными индексами по убыванию
46 33 16 12 9 -3 -11 -12 -28 -40
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота