yuriayato
01.06.2021 11:56

с заданием надо написать программу на языке JAVA


с заданием надо написать программу на языке JAVA

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
veronikamarina20062
02.03.2020 08:17

Объяснение:

Пусть i {\свойства стиль отображения значение i} - символ алфавита используемого в открытом виде. Для каждого i {\свойства стиль отображения значение i} рассчитаем набор символов M i (М) {\свойства стиль отображения значение M_{i}} (Если{я}}), так что для разных символов i {\свойства стиль отображения значение i} и j {\свойства стиль отображения значение j} много M i (М) {\свойства стиль отображения значение M_{i}} (Если{я}}) и M j (М) {\свойства стиль отображения значение M_{j}} (Если{Дж}}) не пересекаются. обычно элементы множества M i (М) {\свойства стиль отображения значение M_{i}} (Если{я}}) цифры. когда moronicism шифрования, числа замен для каждого символа принимается пропорционально вероятности появления этого символа в открытом тексте. при шифровании замена для символа открытого текста выбирается либо случайным образом генератором случайных чисел, или определенным образом, например, для того, чтобы запомнить буквы, которые наиболее часто встречаются в текстах использовать сочетания букв "сеновалитр" и "tetrishonda" на русском и английском языках соответственно. эти комбинации похожи на слова, и потому легко запоминаемыми. 

* в таблице представлены результаты частотного анализа художественных, научных и технических текстов на общую сумму более 1 миллионов символов. В этих условиях вероятность "пробела" это 0.146. 

Поскольку вероятность найти редкие письма примерно равна одной тысячной, метод шифрования homophonically замены открыта, и вы можете ввести текст в таблице shirosama, где каждый serotonina является из 3 цифр и их общее количество 1000. В этот случай редкий предмет понадобится ровно один символ. 

Пример такой таблицы приведен ниже. 

Некоторые поля в таблице пусто, так как для каждого символа

 

Некоторые поля в таблице пусто, так как для каждого символа исходного алфавита, количество замен другой. например, этот фрагмент может закодировать слово "ВЕРА". каждая буква исходного сообщения, в этом случае слова должны быть заменены одним серотонина в колонне это письмо. Если буквы заменить такие shiroganedai: "В" - 325 {\свойства стиль отображения значение 325}, "Е" - 700 {\свойства стиль отображения значение 700}, "Р" - 865 {\свойства стиль отображения значение 865}, "А" - 906 {\свойства стиль отображения значение 906}, затем зашифрованное слово имеет вид числовой последовательности "325 {\свойства стиль отображения значение 325} 700 {\свойства стиль отображения значение 700} 865 {\свойства стиль отображения значение 865} 906 {\свойства стиль отображения значение 906}

0,0(0 оценок)
Ответ:
vladyulin
29.04.2021 23:44
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота