dmitry113114
09.06.2023 21:31

Составить программу для определения следующих выражений S=105*95*85*…*15

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Полина9111111
27.08.2021 09:52

ЖарайдыКестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.

0,0(0 оценок)
Ответ:
dasha1975
31.05.2023 03:24
// тестировалось на C#.Net Framework 4.5
using System;

class Program
{
    static void Main()
    {
        int x1 = 2, y1 = 1;
        int x2 = 6, y2 = 5;
        int x3 = 10, y3 = 1;

        var a = Distance(x2, y2, x3, y3);
        var b = Distance(x1, y1, x3, y3);
        var c = Distance(x2, y2, x1, y1);

       
        Console.WriteLine("S = {0}", Square(a, b, c));
        Console.ReadKey();
    }

    //растояние между точками
    static double Distance(int x1, int y1, int x2, int y2)
    {
        return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
    }

    //формула герона
    static double Square(double a, double b, double c)
    {
        var p = (a + b + c) / 2;
        return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
    }

    // теорема косинусов
    static double Angle(double a, double b, double c)
    {
        return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
    }

    static bool IsAcuteAngel(double alpha)
    {
        return alpha < Math.PI / 2;
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота