AlexMason03
20.07.2022 23:56

Написать программу, которая: Задайте два вектора А (n) и В (m). Выполню Такие задачи:

1. определить вектор С так, чтобы все его элементы были Уровни сумме соответствующих элементов векторов А и В, если в А и В разница между любыми двумя соседними элементами НЕ превосходит максимального значения двух векторов; если же превосходит, то D будет вектором Нулевой элементов Количество которых доривнюватиме целой части максимального значения с двух векторов;

2. Определить произведение элементов вектора, расположенных между дерет достойной Нулевой элементами;

3. Преобразовать вектор так, чтоб сначала располагались все элементы, равные нулю, а потом - все остальные элементы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Софья3601
02.04.2020 19:36
#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
    using namespace std;
    cout << "Enter size of array: ";
    int N;
    cin >> N;
    int * ARR = new int[N];
    srand(time(0));
    int i;
    for (i = 0; i < N; ++i)
        ARR[i] = rand() % 100 + 1;

    cout << "Here is an original array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    int temp = ARR[N - 1];
    for (i = N - 1; i > 0; --i)
        ARR[i] = ARR[i - 1];
    ARR[0] = temp;

    cout << "\nHere is a new array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    return 0;
}
0,0(0 оценок)
Ответ:
РоманРазумный
23.02.2023 03:28
#include <iostream>
using namespace std;
int main()
{
cout <<"4,4"<<endl;cout <<"4,5"<<endl;cout <<"4,6"<<endl;cout <<"4,7"<<endl;cout <<"4,8"<<endl;cout <<"4,9"<<endl;cout <<"5,0"<<endl;cout <<"5,1"<<endl;cout <<"5,2"<<endl;cout <<"5,3"<<endl;cout <<"5,4"<<endl;cout <<"5,5"<<endl;cout <<"5,6"<<endl;cout <<"5,7"<<endl;cout <<"5,8"<<endl;cout <<"5,9"<<endl;cout <<"6,0"<<endl;cout <<"6,1"<<endl;cout <<"6,2"<<endl;cout <<"6,3"<<endl;cout <<"6,4"<<endl;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота