Messi1444
22.03.2021 11:41

1.Составьте программу закрашивания буквы "Т", размерами четыре клетки по вертикали и три по горизонтали. Начальное положение Робота - где-то в центре поля.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
gerasi1
25.09.2020 23:06

Объяснение:

#include <iostream>

using namespace std;

int main()

{

   int N, average, sum = 0, counter = 0;

   cout << "Введите размер массива (N): ";

   cin >> N;

   int A[N];

   cout << "Вводите значения массива: " << endl;

   for (int i = 0; i < N; ++i){

       cin >> A[N];

       sum += A[N];

   }    

   average = sum / N;    

   cout << "Среднее арифметическое: " << average << endl;    

   for (int i = 0; i < N; ++i){

       if(A[i] < average){

           counter++;

       }

   }

   cout << "Кол-во элементов: " << counter << endl;

   return 0;

}

0,0(0 оценок)
Ответ:
06637381
26.01.2023 13:38
Const n=10; m=3;
var 
a:array[1..n,1..m] of integer;
i,j,s,k:integer; p:real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=random(81)+20;
   write(a[i,j]:4);
  end;
  writeln;
 end;
s:=0;
for i:=1 to n do
 for j:=1 to m do s:=s+a[i,j];
p:=s/n*0.8;
writeln('p = ',p:5:2);
writeln('Зачислены:');
k:=0;
for i:=1 to n do
 begin
 s:=0;
 for j:=1 to m do s:=s+a[i,j];
 if s>=p then begin write(i,' '); k:=k+1; end;
 end;
writeln;
writeln('k = ',k);
end.

Пример:
Исходный массив:
  58  79  60
  96  63  97
  90  97  57
  29  68  25
  38  75  65
  54  69  42
  44  70  47
  39  49  24
  27  64  36
  68  21  64
p = 137.20
Зачислены:
1 2 3 5 6 7 10 
k = 7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота