владгалимуллин
04.02.2020 20:20

Составить программу, которая вычисляет сумму введенных цифр до тех пор пока вводимое число не равно нулю​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
papuh
02.10.2022 09:00
#include "stdafx.h"
#include "iostream"    //Подключаем библиотеку ввода вывода
#include "math.h"      //библиотека математических функций

#include <windows.h>

using namespace std;   //подключение пространства имён std - открывает
//доступ к cin и cout из библиотеки iostream

int main()   //начало программы
{
SetConsoleCP(1251);   //если будешь компилировать     SetConsoleOutputCP(1251);   //то это для подключения русского языка в консоли

float x, y, z;   //объявление вещественных переменных
cout<<"Введите значение X";   //вывод строки
cin>>x;   //вводим число
y=sqrt(x);   //считаем y
if ((x<3) || (x>8))    //условие. если (x<3 или x>8)  
z=x*y; //есил истино z=x*y
else z=x+y; //иначе z=x+y

cout<<"z= "<<z;  //вывод результата

cout<<"Для завершения программы нажмите любую клавишу...";
cin.get();
cin.get();
return 0;
}
0,0(0 оценок)
Ответ:
morozandrey7474
02.10.2022 09:00

Объясню на примере первой задачи.

Перед нами написана программа (алгоритм) на языке псевдокода.

В начале программы объявляются переменные, с которыми мы будем работать. В данном случае, объявляются переменные s и n целочисленного типа (цел). Дальше идет присвоение переменной s значения 1. нц говорит о том, что дальше идет цикл. Каждую его итерацию (шаг) будет выполняться его тело (все, что между нц и кц).  Конструкция для x от n до m говорит о том, что каждую итерацию переменная x будет увеличиваться на единицу (если указан шаг, т.е. конструкция выглядит так: для x от n до m шаг y, то будет увеличиваться на y) от числа n до числа m. Как только x будет равна m, цикл прекратится и будут выполняться действия после него. В нашем случае переменной n присваивается 3, выполняется тело s:=s*3. Т.е. после этого шага s будет равна 9. Теперь новая итерация. Переходим в начало цикла. Переменной n присваивается 4 (в предыдущий раз было 3). И опять выполняется действие s:=s*3. s становится равной 27. Потом опять новая итерация. И так далее. Когда n будет равна 5 ,то произойдет последняя итерация. Дальше пойдет вывод s, который после 4 итераций (n от 2-х до 5-ти включительно) будет равна 81.

Итерации более детально:

1. n = 2; s = 1*3 = 3

2. n = 3; s = 3*3 = 9

3. n = 4; s = 9*3 = 27

4. n = 5; s = 27*3 = 81

Все, цикл завершился.

ответы:

1) 81

2) 50

Итерации более детально:

1. n = 3; s = 0+2*3 = 6

2. n = 4; s = 6+2*4= 14

3. n = 5; s = 14+2*5 = 24

4. n = 6; s = 24+2*6 = 36

5. n = 7; s = 36+2*7 = 50

3) 13

4) 11

5) 121

6) 120

7) 38

8) 20

9) 40

Заметим, что в данной задаче указан шаг (step 2). Это значит, что каждую итерацию k будет увеличиваться не на 1-цу, а на 2-ку.

Итерации более детально:

1. k = 6; s = 0+10 = 10

2. k = 8; s = 10+10 = 20

3. k = 10; s = 20+10 = 30

4. k = 12; s = 30+10 = 40

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота