TheCosmos
12.09.2020 05:00

Напишите программу для трехзначного числа является ли число "перевертышем" (палиндромом), т.е. числом десятичная запись которого читается одинаково слева направо и справа налево. 122 - не перевертыш, 121- перевертыш, 222 - перевертыш(Python)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladik2ppp
05.12.2021 05:53

Сначала сделал с рекурсивной функции, но затруднение было только с суммой элементов, по этому написал через цикл как впрочем и должно быть.

Console.WriteLine("Введите число");

           int x = Convert.ToInt32(Console.ReadLine());

           int y = x;

           int sum = 0;

           for (int i = 0; i < 4; i++)

           {

               y = x % 10;

               x = x / 10;

               Console.Write(y);

               sum = sum + y;

               

           

           }

           Console.Write(" = " + sum);

           

           Console.ReadLine();

0,0(0 оценок)
Ответ:
Karakulova2004
05.12.2021 05:53
Был на свете человек он был обичный как все любил призидента и был нормальным но один раз когда он пошоо гулять с друзьями он упал в яму наткнувшись на блок он кго тронул и о него было видение потом его нашли копы работающие на призедента они розказали ему что Президент взорвет мир и только он мон мир с блока его хотели питать но пришел парень который его началась погоня и парень понял (его звали Дикарь) что человек (он де Эммет) не избранный продалдалась погоня и коп вистрельнул в Эммета пушкой (котороя не взривала а прилипила жучка)
Коп их стрелял но бэтмен их они полетели в Заоблачную даль
К другим крутим людям которие б им мир но из-за жучка прилетели копы и взорвали Заоблачную даль всех посадили в тюрмю но банда Эммета уцелела они пошли к Президенту гле их ожидали и словили все билы без но Эммет вибралса гле подертвовал собой для других и они закончили то что Эммет начал надавали люлей Президенту и копам и мир не взорвался а Эммет вижил!
Конец!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота