555сармат555
04.01.2021 11:43

Скодом на python, вот :
напишите программу, которая позволит проверять пароль
на сложность. воспользуйтесь строковыми .
проверку пароля следует проводить по таким критериям:
1. длина: от 5 символов.
2. буквы латинского алфавита в верхнем и нижнем реги-
стре: a, a, z, z.
3. цифры: от 0 до 9.
4. символы: @, #, %, & .
"можете воспользоваться методом isnumeric() для про-
верки строки на наличие цифр. метод isupper() позволяет
выполнить проверку букв в верхнем регистре, islower()
следует использовать для проверки нижнего регистра. в свою
очередь, isalpha() позволит определить символ в строке."

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Wensansys
20.09.2022 22:51
Uses crt,graphABC;
var a,m,n,j,i,x1,y1,x2,y2,x3,y3,x4,y4,kg,kv,p:integer;
    k:real;
    
procedure kvadrat;//рисование 1 квадрата
begin
setpencolor(clBlue);
moveto(x1,y1);
lineto(x2,y2);
lineto(x3,y3);
lineto(x4,y4);
lineto(x1,y1);
end;
 
begin
hidecursor;
repeat
write('Сторона квадрата от 20 до 100 a=');
read(a);
until a in [20..100];
repeat
writeln('Введите 2 числа для определения соотношени m<n:');
read(m,n);
until m<n;
clearwindow;
k:=m/n;//отношение
kg:=windowwidth div a+1; //кол. кв. по горизонтали
kv:=windowheight div a+1; //по вертикали
for j:=1 to kg do
for p:=1 to kv do
 begin
  for i:=1 to 50 do //рисуем 50 вложенных квадратов в 1 месте
   begin
    kvadrat;
    x1:=trunc(x1+(x2-x1)*k); y1:=trunc(y1+(y2-y1)*k);
    x2:=trunc(x2+(x3-x2)*k); y2:=trunc(y2+(y3-y2)*k);
    x3:=trunc(x3+(x4-x3)*k); y3:=trunc(y3+(y4-y3)*k);
    x4:=trunc(x4+(x1-x4)*k); y4:=trunc(y4+(y1-y4)*k);
   end;
x1:=a*(j-1); y1:=a*(p-1); //на новое место
x2:=a*j; y2:=a*(p-1);
x3:=a*j; y3:=a*p;
x4:=a*(j-1); y4:=a*p;
end;
 
 
end.

Втетради нарисовать орнамент из разноцветных прямоугольников, ромбов, квадратов, подготовить програм
0,0(0 оценок)
Ответ:
mrarmen1999mailru
22.11.2021 07:31
Приведенная программа принимает целые числа и выводит два значения: a - количество цифр в числе и b - произведение цифр, составляющих число. При вводе нуля программа завершает работу.  Ввод отрицательных чисел игнорируется.
1) При исполнении этой программы на экран было сначала выведено число 2, затем число 15. НАИМЕНЬШЕЕ значение переменной x, для которого это возможно, равно С) 35
Здесь количество цифр равно двум, а их произведение равно 15. Число 15 представимо в виде произведения двух однозначных чисел только в виде 3х5 или 5х3. Следовательно, наименьшим числом могло быть только 35.
2) При исполнении этой программы на экран было сначала выведено число 2, затем число 15. НАИБОЛЬШЕЕ значение переменной x, для которого это возможно, равно B) 53
Решение аналогично предыдущему, но выбирается наибольшее число, т.е. 53.
3) НАИМЕНЬШЕЕ значение переменной b, которое может быть выведено на экран этой программой, равно Е) 0
Минимальное значение произведения n однозначных чисел будет равно нулю, если среди этих чисел встретить хотя бы один ноль.
4) При исполнении этой программы на экран было сначала выведено число 2. НАИБОЛЬШЕЕ значение переменной b, которое может быть выведено на экран, равно А) 81
Максимальное произведение двух однозначных чисел равно 9х9=81.
5) НАИМЕНЬШЕЕ значение переменной a, которое может быть выведено на экран этой программой, равно D) 1
Понятно, что чисел с количеством знаков, меньшим единицы, быть не может.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота