viper998
24.12.2022 18:54

Надо написать программу на кумире которая решит данную задачу: Цикл с постусловием «Часы с Кукушкой»

Требуется рассчитать время работы батарейки часах кукушкой. если B с известно, что заряда хватает примерно на 1000 звуковых сигналов «Ky-ky>>. Однократный звуковой сигнал звучит, когда минутная стрелка показывает 30 минут. Начало каждого часа сопровождается повторением сигнала столько раз. сколько показывает часовая стрелка (от 1 до 12).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dangoreh
30.12.2021 08:46
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var a,n,k,i,j,s:integer;
begin
  writeln('Количество учеников и количество оценок');
  readln(n,k);
  for i:=1 to n do begin
    for j:=1 to k do begin
      write('Ученик № ',i, ' оценка № ',j,' = ');
      readln(a);
      s:=s+a;
    end;
  end;
  println('Средняя оценка группы ',s/(n*k):6:3);
end.

Тестовое решение:
Количество учеников и количество оценок
3 3
Ученик № 1 оценка № 1 = 3
Ученик № 1 оценка № 2 = 4
Ученик № 1 оценка № 3 = 4
Ученик № 2 оценка № 1 = 5
Ученик № 2 оценка № 2 = 4
Ученик № 2 оценка № 3 = 4
Ученик № 3 оценка № 1 = 4
Ученик № 3 оценка № 2 = 3
Ученик № 3 оценка № 3 = 3
Средняя оценка группы  3.778
0,0(0 оценок)
Ответ:
yaroslavus
25.07.2022 14:07
После того как мы узнали, что такое уравнение, и научились решать самые простые из них, в которых находили неизвестное слагаемое, уменьшаемое, множитель и т.п., логично познакомиться с уравнениями и других видов. Следующими по очереди идут линейные уравнения, целенаправленное изучение которых начинается на уроках алгебры в 7 классе. Понятно, что сначала надо объяснить, что такое линейное уравнение, дать определение линейного уравнения, его коэффициентов, показать его общий вид. Дальше можно разбираться, сколько решений имеет линейное уравнение в зависимости от значений коэффициентов, и как находятся корни. Это позволит перейти к решению примеров, и тем самым закрепить изученную теорию. В этой статье мы это сделаем: детально остановимся на всех теоретических и практических моментах, касающихся линейных уравнений и их решения. Сразу скажем, что здесь мы будем рассматривать только линейные уравнения с одной переменной, а уже в отдельной статье будем изучать принципы решения линейных уравнений с двумя переменными.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота