elnur22
20.07.2022 04:56

Составить программу для нахождения 1 наименьшего из 4 чисел, после чего умножить его на 2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lerashherbakov
26.04.2021 20:00

uses crt ;

function min ( a , b :real ) :real;

begin

if a<b then min := a

else min := b ;

end;

var x , y , z , t :real;

begin

clrscr ;

writeln ( 'Введите 4 числа:' ) ;

readln ( x , y , z , t ) ;

write ( 'Минимальное=' , min( min( x , y ) , min( z , t )) : 0 : 2 ) ;

0,0(0 оценок)
Ответ:
MurMraz1
26.04.2021 20:00

Приведу пример на Haskell

main :: IO ()main = do  a <- read $ getLine :: IO Int  b <- read $ getLine :: IO Int  c <- read $ getLine :: IO Int  d <- read $ getLine :: IO Int  print $ 2 * minimum [a, b, c, d]
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота