Dima98891
27.03.2020 07:42

Составьте программу, которая обрабатывает следующие данные: ФИО, знак зодиака, дата рождения. Вывести список людей, имеющих тот же знак зодиака, что и введенная дата с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
leila323
30.11.2020 07:38
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
0,0(0 оценок)
Ответ:
Ксюша99009
11.01.2023 15:19

   кандидат технических наук (1971)

   доктор технических наук (1991)

   доцент (1976)

   профессор (1993)

   заслуженный профессор Санкт-Петербургского государственного политехнического университета (2006)

Членство в профессиональных обществах

   член Американского Математического общества (с 1975 г.)

   член Association for Computing Machinery (ACM)

   член IEEE Computer Society

   член программных комитетов нескольких продолжающихся международных конференций, в частности, ИММОД, CoLoS, SEEMAS, РаСТ и других

   член редколлегий журналов "Моделирование и анализ информационных систем", "Научно-технические ведомости СПбГПУ", "Bulletin of the Novosibirsk computing center"

   член двух специализированных советов по защите докторских диссертаций

   эксперт Российского фонда фундаментальных исследований (2012 г.)

   федеральных эксперт научно-технической сферы (ГУ РИНКЦЭ при министерстве промышленности, науки и технологий РФ, свидетельство № 11313707.281)

   член Правления Национального общества имитационного моделирования

   член Научно-Методического Совета   по информатике Министерства образования и науки РФ. Секция фундаментальных основ информатики

Другие заслуги

   премия Правительства Санкт-Петербурга за выдающиеся достижения в области высшего и среднего профессионального образования в номинации "Научные достижения повышению качества подготовки специалистов и кадров высшей квалификации" (2011)

   премия СПбГПУ за лучшие учебные и научные издания (за монографию "Model Checking. Верификация параллельных и распределенных программных систем") (2011)

   диплом фирмы Интел за научный проект "Верификация взаимодействующих временных автоматов"  (2001)

   инструктор альпинизма (1964)

   кандидат в мастера спорта по альпинизму(1969)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота