miryayatatianap08x2w
08.06.2022 10:00

Задано два целочисленных массива случайных чисел. Написать программу, которая формирует новый массив, элемент которого вычисляется по формуле C(i)=A(i)+B(i). Массивы распечатать тремя столбцами. Pascal

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mariamuraskina9
07.10.2022 16:38
// PascalABC.NET 3.2, сборка 1345 от 24.11.2016
// Внимание! Если программа не работает, обновите её версию!

function Len(ax,ay,bx,by:real):=sqrt(sqr(bx-ax)+sqr(by-ay));

var
  x,y,L:array[1..4] of real;
begin
  Writeln('Введите координаты четырех точек (парами х,y)');
  for var i:=1 to 4 do Read(x[i],y[i]);
  for var i:=1 to 3 do
    L[i]:=Len(x[i],y[i],x[i+1],y[i+1]);
  L[4]:=Len(x[4],y[4],x[1],y[1]);
  var s:=0.0;
  for var i:=1 to 4 do s+=L[i];
  Writeln('P=',s)
end.

Пример
Введите координаты четырех точек (парами х,y)
-5 -4.7 -3.2 6.7 5.1 8 7.4 -6.13
P=46.7405707422041

Во вложениях приведено решение этой же задачи в онлайн-калькуляторе. ответ совпадает.

Информатика. паскаль. по заданным декартовым координатам вершин четырехугольника p1(x1,y1),p2(x2,y2)
Информатика. паскаль. по заданным декартовым координатам вершин четырехугольника p1(x1,y1),p2(x2,y2)
0,0(0 оценок)
Ответ:
умница20063
19.10.2022 22:45
Притянуто "за уши", но такое уж задание несуразное. Видимо, для старых версий языка.

// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

function Summa(a:array of integer):=a.Sum;

begin
  var a:=ArrRandom(10,-99,99); a.Println; Writeln;
  var b:=ArrRandom(20,-99,99); b.Println; Writeln;
  var c:=ArrRandom(30,-99,99); c.Println; Writeln;
  Writeln('S=',Summa(a)+Summa(b)+Summa(c))  
end.

Пример
53 34 13 64 79 28 -98 -43 -19 23

96 -18 48 61 -70 -16 92 0 27 65 -68 -17 -77 90 -13 69 46 85 71 -44

-21 65 -56 31 56 25 37 50 -35 52 91 -94 12 -98 -51 -73 6 -31 -7 -32 35 -88 -53 63 -93 -29 11 22 -23 -89

S=244
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота