aigulkordai
09.11.2020 08:38

№12. Всего с начала суток N секунд. Напишите программу, которая определяет, сколько часов, минут и секунд с начала суток. Значение N вводится с клавиатуры.
№13.
Глава центрального банка России сообщила, что инфляция в России в 2016 году составит не более определённого P% в месяц. Напишите программу, которая определит возможный рост цен (в %) за год.
ПОЖАЙЛУСТА НУЖЕН ОТВЕТ,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sawensia
12.01.2023 05:40
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=ArrRandom(30,1960,2016); a.Println;
  var iFirst:=a.IndexMin;
  var iLast:=iFirst;
  var vMin:=a[iFirst];
  for var i:=29 downto iFirst+1 do
    if a[i]=vMin then begin iLast:=i; break end;
  if iLast=iFirst
  then Writeln('Самый старший человек номер ',iFirst+1)
  else Writeln('Первый из самых старших людей имеет номер ',
    iFirst+1,', последний из людей этого возраста - номер ',
    iLast+1)
end.

Тестовое решение
1987 1971 1974 1989 1989 1960 1987 2016 1992 1962 1971 2011 1993 1962 2008 1994 1994 1976 1988 2014 2011 1960 1971 2000 1973 2010 1964 1976 1971 1993
Первый из самых старших людей имеет номер 6, последний из людей этого возраста - номер 22
0,0(0 оценок)
Ответ:
Алёнажж
28.04.2022 02:15
Var x,y,z: real;
      t: integer;
begin writeln('введите х и у');
          readln(x,y);
          z:=sqrt(sqr(x)-sqr(y));
          t:=0;
          while (z>0,1) do
          begin t:=t+1;
                    z:=0,98*z;    {если 2% от изменяющегося расстояния до пола;
                   если же имеется ввиду 2% от исходного расстояния,
                   то нужно будет ввести новую переменную
                   или присвоить исходное значение z, например х,
                   то есть сразу после z:=sqrt(sqr(x)-sqr(y)); написать x:=z;
                   Формула (оператор) z:=0,98*z;  изменится так:
                   z:=z-x*0,98}
           end;
          writeln('палка упадет через ', t,' мин.');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота