настя200336
25.03.2020 05:53

Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. количество чисел должно задаваться во время работы программы. (цикл для)(паскаль )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
shark741
06.07.2020 07:44
Program Nooobodyyy;
uses crt;
var
  i,how:integer;
  ch,appr,sum:real;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
  writeln('Программа запрашивает N дробных чисел и находит их среднее арифметическое');
  sum:=0;
  write('Введите количество чисел: '); readln(how);
  for i:=1 to how do
    begin
      write('Введите ',i,'-e число: '); read(ch);
      sum:=sum+ch;
    end;
  appr:=sum/how;
  writeln('Cреднее арифметическое равно ',appr:8:2);
end.
0,0(0 оценок)
Ответ:
nslava783
06.07.2020 07:44
Var
  i, count : integer;
  summ, temp : real;
begin
  summ := 0;
  readln(count);
  for i := 1 to count do
  begin
    readln(temp);
    summ := summ + temp;
  end; 
  writeln(summ / count);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота