Finzz
25.09.2021 20:05

1.Составьте программу вычисления длины окружности и площади круга по заданному радиуса круга. 3. Напишите программу вычисления среднего арифметического значения трех заданных чисел., составить программы.
НА ЯЗЫКЕ ПИТОН СОСТАВИТЬ ПРОГРАММЫ.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
FrankAnDWay
21.09.2020 03:43
Существуют два перевода
1.
универсальный, который годится для перевода из любой системы счисления в любую. Число из исходной системы надо перевести в основную, десятичную систему
754_8 = 7*8^2+5*8^1+4*8^0 = 492_10
и затем перевести в целевую систему счисления
492/16=30 остаток от деления 12 - шестнадцатеричная цифра С
30/16=1 остаток от деления 14  - шестнадцатеричная цифра E
1/16=0 остаток от деления 1 - шестнадцатеричная цифра 1
754_8 = 492_10 = 1EC_16
- и второй попроще, основанный на том, что и восьмеричная и двоичная системы - это системы с основанием, равным степени двойки, и перевод из них в двоичную и обратно очень прост
Каждая восьмеричная цифра соответствует трём двоичным, каждая шестнадцатеричная цифра - четырём двоичным, и преобразования выполняются без арифметических действий, простой перегруппировкой бит из групп по 3 в группы по 4
754_8 = 111 101 100_2 = 1 1110 1100_2 = 1EC_16
0,0(0 оценок)
Ответ:
tiamaressp035gw
30.06.2020 12:59
#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int n,sum=0; 
float y,k=0; 
cin >> n; 
int *mass = new int[n]; 
for (int i = 0;i < n;++i) 
{
cin >> mass[i]; 

for (int i = 0;i < n;++i) 

if (mass[i] >0 )
{
k++;
y=pow(mass[i],2); 
cout<<y;
sum+=mas[i]
}

system("pause"); 
}

2)#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота