.Решите , хоть одно задание, 8 класс, Python 1 1)Напишите программу которая проверяет введенное число на четность и нечетность.

Например:

5 - нечетное число

6 - четное число
2) Различаются ли результаты работы программ А и Б?

А) print (‘Как тебя зовут?’)

name = input ()

Б) name = input (‘Как тебя зовут?’)

​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Лилия22111048483
23.03.2022 02:27

Информатика – очень современная область знаний. Мы изучаем ее в школе, как предмет, но не только. Зачем нужна информатика? В современном мире мы каждый день сталкиваемся с новейшими технологиями. У меня дома есть компьютер, подключенный к Интернету. Когда я ищу что-нибудь в Интернете или пишу другу сообщение, то использую достижения информатики.

Вокруг нас – море информации, а наука информатика как раз решает вопросы, как управлять этим морем. Поэтому она и носит такое название. Без достижений информатики не существовало бы компьютеров, Интернета и других новых технологий, которые уже стали для нас привычны. Не было бы даже вычислительных машин, которые могут производить сложные расчеты за доли секунды. А расчеты нужны везде: на производстве, в банках, на линиях транспорта. Жизнь была бы намного сложнее, если бы информатика не развилась до такого уровня, как сейчас.

Не было бы поисковых систем, с которых сейчас можно отыскать нужны информацию. Я не говорю, что можно найти любую информацию о любом человеке, потому что в мире всегда остаются тайны и секреты. Но большинство информации, полезной в учебе и повседневной жизни, найти можно. Ну, и море всякого интересного тоже. Еще лет двадцать назад для этого пришлось бы идти в библиотеку и рыться там полдня.

Возникает вопрос, зачем изучать информатику всем школьникам? Ведь далеко не все станут программистами, системными администраторами, веб-дизайнерами? Наверное, смысл этого в том, чтобы все понимали, с чем они сталкиваются каждый день, как это действует. Ведь не зря наше время называется информационной эпохой.

0,0(0 оценок)
Ответ:
riga04
18.12.2021 19:11
#!/usr/bin/env python
# coding: utf-8
"""Определение типа треугольника по сторонам.
Python 2.X.
"""

msg = 'Введите стороны треугольника: '
input = raw_input(msg).split()

try:
    a, b, c = [float(i) for i in input]
except ValueError:
    print('Введены не числовые значения! Выход...')
    quit()

if (a >= b + c or
    b >= a + c or
    c >= a + b):
    print('Не', end=' ')
elif a ** 2 + b ** 2 == c ** 2:
    print('Прямоугольный', end=' ')
elif (a ** 2 + b ** 2 > c ** 2 and
      a ** 2 + c ** 2 > b ** 2 and
      c ** 2 + b ** 2 > a ** 2):
    print('Остроугольный', end=' ')
else:
    print('Тупоугольный', end=' ')
print('треугольник')
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота