жанель93
12.08.2022 18:16

Напишите программу которая присваивает введенному номеру имя

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
WinxPolina05
24.04.2023 05:53

1) создать базу данных Access \Мои документы\Класс\Фамилия.

2) Создать таблицы (при создании таблиц использовать подстановку для

необходимых полей):

СОТРУДНИКИ ОТДЕЛЫ ДОЛЖНОСТИ

Имя поля имя поля имя поля

Таб_№ Отдел Должность

ФИО Оклад

Дата приема на работу

Дата увольнения

Должность

Пол

Курит

Отдел

Для поля [сотрудники]![Дата приема на работу] установить следующие

свойства:

Свойство Значения

Значение по умолчанию текущая дата

Условие на значение

текущей даты

Сообщение об ошибке Дата приема не должна быть

больше текущей даты

3) связать таблицы и обеспечить целостность данных, позволяя каскадное изменение

данных и не позволяя каскадное удаление.

4) с мастера форм создать формы Ф_ сотрудники, Ф_ отделы,

Ф_ должности для внесения данных в соответствующие таблицы.

5) заполнить таблицы следующими данными:

ОТДЕЛЫ ДОЛЖНОСТИ

Отдел Должность Оклад

Рекламы Директор

Маркетинга главный бух.

Дирекция Менеджер

Специалист

Экономист

6) заполнить таблицу сотрудники следующими данными:

Таб_ № ФИО

Дата

приема на

работу

Дата

увольнение должность пол курит отдел

5001 Степанов А. В. 20.01.1990 01.06.1990 Менеджер Ч  Рекламы

5002 Юматов А. В. 10.06.1990 Менеджер Ч Рекламы

2005 Ахматова Э.Н. 06.10.1994 Главный

бух.

Ж  Бухгалтерия

3200 Агутин И. Н.07.11.1998 05.03.2020 Экономист Ч  Бухгалтерия

1321 Панова В. А. 05.03.1990 Директор Ж  Дирекция

1103 Короленко Л. И 20.06.1995 Специалист Же Маркетинга

3233 Багрянов А. А. 07.03.2021 Экономист Ч Бухгалтерия

7) создать запросы:

a. История принятия на работу (сортировка по дате) за период с 01.01.1995 по

01.01.2000 включительно.

Дата приема на работу ФИО Таб_№ отдел должность Оклад

b. Список (отсортировать по ФИО) работающих рабочих в виде:

Таб_ № ФИО Пол Дата приема на работу Отдел Должность Оклад Курит

c. Суммарное значение должностных окладов по отделам (отсортировать по віддвлам):

Отдел Общая сумма окладов по отделу

8) По данным запросов создать:

a. Простой отчет.

b. Отчет, который вмещает уровни группировки с использованием итоговых значений.

Задание Макс.

2 20

3 10

4 10

5 0

6 0

7а 10

7в 15

7с 15

8а 5

8в 15

Всего 100

Объяснение:

Перевёл

0,0(0 оценок)
Ответ:
Ksenichka777
10.07.2020 19:07
1. "Школьное" решение

// PascalABC.Net 3.0, сборка 1066
var
  s,s1:string;
  i:integer;
  a:char;
begin
  Write('Введите натуральное число любой длины :'); Readln(s);
  Write('Введите цифру, которую надо удалить: '); Readln(a);
  s1:='';
  for i:=1 to Length(s) do
    if s[i]<>a then s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793

2. Современное решение (так в школе почему-то не учат)

// PascalABC.Net 3.0, сборка 1066
begin
  var s:=ReadString('Введите натуральное число любой длины :');
  var a:=ReadChar('Введите цифру, которую надо удалить: ');
  Write('Результат: ',s.Replace(a,''));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота