bakulya2005ma
08.10.2021 01:16

Написать программу на языке pelles c решить уравнение sin(x) = cos(x) при 0.0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fortunazanna
13.10.2020 22:46

ответ:Пример 1. Составить алгоритм запуска программы Paint в ОС Windows 7.

Вспомним из курса информатики 5 класса порядок действий для запуска программы Paint.

Войти в меню «Пуск».

Войти в пункт «Все программы».

Войти в пункт «Стандартные».

Выбрать программу «Paint».

Данный алгоритм в виде блок-схемы имеет следующий вид:

 

Рис. 1. Блок-схема к примеру 1.

 

Составление алгоритмов с ветвлениями

Рассмотрим пример на составление алгоритмов с ветвлениями.

Пример 2. Составьте алгоритм для перехода дороги на светофоре.

Рис. 2. Светофор (Источник).

Возможны следующие ситуации: в тот момент, когда мы подошли к дороге горел красный или зелёный свет. Если горел зелёный свет, то можно переходить дорогу. Если же горел красный свет, то необходимо дождаться зелёного – и уже тогда переходить дорогу.

Таким образом, алгоритм имеет следующий вид:

Подойти к светофору.

Посмотреть на его свет.

Если горит зелёный, то перейти дорогу.

Если горит красный, то подождать, пока загорится зелёный, и уже тогда перейти дорогу.

Блок-схема данного алгоритма имеет вид:

Рис. 3. Блок-схема к примеру 2.

 

Составление циклических алгоритмов

Рассмотрим пример на составление циклического алгоритма. Мы уже несколько раз обсуждали перевод чисел из десятичной системы в двоичную. Теперь пришло время чётко сформулировать этот алгоритм.

Напомним, что его принцип состоит в делении числа на 2 и записей остатков, получающихся при делении.

Пример 3. Составить алгоритм перевода чисел из десятичной системы в двоичную.

То есть, алгоритм будет выглядеть так:

Если число равно 0 или 1, то это и будет его двоичное представление.

Если число больше 1, то мы делим его на 2.

Полученный остаток от деления записываем в последний разряд двоичного представления числа.

Если полученное частное равно 1, то его дописываем в первый разряд двоичного представления числа и прекращаем вычисления.

Если же полученное частное больше 1, то мы заменяем исходное число на него и возвращаемся в пункт 2).

Объяснение:

0,0(0 оценок)
Ответ:
olyadudina98
09.04.2022 14:19
1. "Современный вариант"

// PascalABC.NET 3.0, сборка 1076
begin
  var n:=ReadInteger('Введите количество элементов массива: ');
  var a:=ArrRandom(n,1000,10000);
  Write('Исходный массив: ',a,#13#10);
  Write('Множество цифр из разряда сотен: ');
  a.Select(x->(x mod 1000) div 100).Sorted.Distinct.Println(',')
end.

Тестовое решение:
Введите количество элементов массива: 8
Исходный массив: [9374,4420,8856,8274,7555,2461,8302,6325]
Множество цифр из разряда сотен: 2,3,4,5,8

2. "Школьный вариант"

// PascalABC.NET 3.0, сборка 1076
var
  i,n:integer;
  sd:set of 0..9;
  a:array[1..50] of integer;
begin
  Write('Введите количество элементов массива: '); Read(n);
  Randomize;
  Write('Исходный массив: ');
  sd:=[];
  for i:=1 to n do begin
    a[i]:=Random(9001)+1000;
    Write(a[i],' ');
    Include(sd,(a[i] mod 1000) div 100)
    end;
  Writeln;
  Write('Множество цифр из разряда сотен: ');
  for i:=0 to 9 do
    if i in sd then Write(i:2);
  Writeln
end.

Тестовое решение:
Введите количество элементов массива: 8
Исходный массив: 5332 4215 7231 3399 6989 8904 7804 3517
Множество цифр из разряда сотен:  2 3 5 8 9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота