viktoria168
19.03.2021 16:47

Напишите программу. Удалить из текста все слова с нечетным количеством символов и перевернуть все слова с четным количеством символов. Язык С++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
drsamsoff
19.07.2021 12:46

var 

  a, b, c: real;

 

begin

  writeln('Введите 3 любых числа');

  readln(a, b, c);

  if (a < b) and (a < c) then writeln(a, ' - наименьшее число');

  if (b < a) and (b < c) then writeln(b, ' - наименьшее число');

  if (c < a) and (c < b) then writeln(c, ' - наименьшее число');

  if (a > b) and (a > c) then writeln(a, ' - наибольшее число');

  if (b > a) and (b > c) then writeln(b, ' - наибольшее число');

  if (c > a) and (c > b) then writeln(c, ' - наибольшее число');

  readln; //Убрать если среда разработки не Turbo Pascal

end.

0,0(0 оценок)
Ответ:
revernastyn
19.07.2021 12:46
Разветвляющийся алгоритм

Var a,b,c,d,e:integer;

Begin

Writeln('Введите значения переменных');

Readln(a,b,c,d,e);

If (a>b) and (a>c) and (a>d) and (a>e) tnen

Writeln('Наибольшее из 5 чисел ', a)

Else

If (b>a) and (b>c) and (b>d) and (b>e) tnen

Writeln('Наибольшее из 5 чисел ', b)

Else

If (c>a) and (c>b) and (c>d) and (c>e) tnen

Writeln('Наибольшее из 5 чисел ', c)

Else

If (d>a) and (d>b) and (d>c) and (d>e) tnen

Writeln('Наибольшее из 5 чисел ', d)

Else

Writeln('Наибольшее из 5 чисел ', e);

End.

Циклический алгоритм

Type

Vector=array [1..10] of integer;

Var m:integer;

a:vector;

i:byte;

Begin

Writeln('Введите значения переменных');

For i:=1 to 5 do

      Readln (a[i]);

For i:=1 to 5 do

If  a[i]>a[i+1] then

m:=a[i];

Writeln('Наибольшее число ', m);

End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота