sicrettry
10.01.2022 16:47

1. Задача №112348. Замена Напишите программу, которая заменяет в символьной строке все вхождения одной подстроки на
другую. Используйте процедуру.
Входные данные
Первая входная строка содержит символьную строку, которую нужно обработать. Во второй и
третьей строках записаны соответственно подстрока-образец (которую нужно менять) и
подстрока-замена.
Выходные данные
Программа должна вывести обработанную символьную строку, в которой все вхождения
подстроки-образца заменены на подстроку-замену.
Примеры
входные данные
abcDEFabcgh
abc
XYZ
выходные данные
XYZDEFXYZgh

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
найксон
10.09.2021 02:59
Заполнение с клавиатуры:

Var
   A:array[1..5] of integer;
   i,O,P:integer;
Begin
Write('Введите массив A(5): ');
O:=0;
P:=0;
For i:= 1 to 5 do
    Begin
    Read(A[i]);
    if A[i] < 0 then O:=O+1
    else if A[i] > 0 then P:=P+1;
    End;
WriteLn('Количество отрицательных: ',O);
WriteLn('Количество положительных: ',P);
End.

Заполнение случайными числами:

Const
   N = 5;
Var
   A:array[1..N] of integer;
   i,O,P:integer;
Begin
Randomize;
Write('Введите массив A(5):');
O:=0;
P:=0;
For i:= 1 to N do
    Begin
    A[i]:=random(2*N+1)-N;
    Write(' ',A[i]);
    if A[i] < 0 then O:=O+1
    else if A[i] > 0 then P:=P+1;
    End;
WriteLn;
WriteLn('Количество отрицательных: ',O);
WriteLn('Количество положительных: ',P);
End.
0,0(0 оценок)
Ответ:
ирина1853
14.10.2022 12:58
Решение 1.

Представим таблицу в виде: (см. Рис. 1)
Получаем уравнение
8 + b1 + 4 = 2*b1 + (b1+2) + 4
Отсюда:
b1 = 3.
Получаем (см. Рис. 2)

Далее, заметим, что сумма по горизонтали и по диагонали равна 15.
Заполняем таблицу (см. Рис. 3)

ответ: С2 = 9

Решение 2.

Заданным свойством (иметь одинаковую сумму по горизонталям, вертикалям и диагоналям) обладает единственный МАГИЧЕСКИЙ КВАДРАТ (не учитывая его повороты и отражения относительно осей).
Это магический квадрат 3х3 с магической суммой 15 (см. Рис. 4)

ответ: С2 = 9

Петя случайно удалил значения некоторых ячеек электронной таблицы. известно, что сумма чисел в каждо
Петя случайно удалил значения некоторых ячеек электронной таблицы. известно, что сумма чисел в каждо
Петя случайно удалил значения некоторых ячеек электронной таблицы. известно, что сумма чисел в каждо
Петя случайно удалил значения некоторых ячеек электронной таблицы. известно, что сумма чисел в каждо
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота