коротенко87
15.09.2020 23:33

Предположим, что у нас есть язык программирования игры <морской бой>, В этот язык входят команды N>-корабль перемещается на одну
клетку вправо; N<- корабль с номером N перемещается на одну клетку
влево, N - корабль с номером N перемещается на одну клетку верх, Nv -
корабль с номером N перемещается на одну клетку вниз; К{команды) -
повторяет команды в скобочках К раз (K>I) отдельные команды пишутся
слитно, между командами пробел тоже не ставится. То есть вся
программа пишется слитно. пример 1, Чтобы перевести корабль с
номером 5 из клетки А І в клетку 10. например, можно выполнить
следующую программу: 9 {5v)9 {5>} прl,{N.{EP 2. Чтобы перевести корабль
с номером 7 из клетки А в клетку 13, например, можно выполнить
следующую программу: 2]7 v4 \7 >\/ 20. Напишите программу для
перехода | 3 4 5 6 7 8 9 10 D корабля 4 из Аб в верхний правый угол

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
valeraKRUT05
18.02.2020 00:49
Пронумеруем дни недели числами от 0 до 6 (0-Вс, 1-Пн, .. 6-Сб).

var
  dow:0..6;
begin
  Write('Введите номер дня недели (0-Вс, 6-сб): ');
  Read(dow);
  case dow of
  0:Writeln('Воскресенье, выходной');
  1:Writeln('Понедельник, 6 уроков');
  2:Writeln('Вторник, 6 уроков');
  3:Writeln('Среда, 7 уроков');
  4:Writeln('Четверг, 6 уроков');
  5:Writeln('Пятница, 6 уроков');
  6:Writeln('Суббота, 6 уроков');
  else Writeln('Введено неверное значение')
  end
end.

Тестовое решение:
Введите номер дня недели (0-Вс, 6-сб): 5
Пятница, 6 уроков
0,0(0 оценок)
Ответ:
MRSinn
18.09.2022 08:25
Держи VBA-версию в Excel 2003.

Delphi у меня 7-й версии. будет чем проект открыть? Код модуля в файле Unit1.pas.

P.S. Что-то zip не грузится, код  - ниже:

procedure TForm1.Button1Click(Sender: TObject);
var
N1, N2, N3: Real;
begin
//Проверок на введённе значения для простоты не делаю
N1:=StrToFloat(Edit1.Text);
N2:=StrToFloat(Edit2.Text);
N3:=StrToFloat(Edit3.Text);

if N1<0 then N1:=N1*N1*N1*N1 else N1:=N1*N1;
if N2<0 then N2:=N2*N2*N2*N2 else N2:=N2*N2;
if N3<0 then N3:=N3*N3*N3*N3 else N3:=N3*N3;

Edit4.Text:=FloatToStr(N1);
Edit5.Text:=FloatToStr(N2);
Edit6.Text:=FloatToStr(N3);
end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота