s1nedesports
11.05.2020 04:45

Напишите программу, которая находит количество двузначных чисел, которые делятся на 7. Используйте оператор for с переменной в диапазоне от 10 до 100 ( in range (10,100) )
Подсказка. Проверить условие можно, используя операцию %

Если N%7==0 - число делится на 7

Пришлите скриншот выполненной программы с выходными данными. Составьте блок-схему алгоритма программы.

3. Составьте таблицу пошагового изменения значений переменных a и k в ходе выполнения программы:
a=20
for k in range(4,7):
a=a-k

k a
20
4
5
6

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Про100zvezda
06.02.2020 10:49
Вот держи
program n_3;var n, i,s, imax: integer;a:array[1..10] of integer;begin//третья прогаwriteln('3 прога');
for i:=1 to 10 do a[i]:=random(50);for i:=1 to 10 do write (a[i],' ');n:=0;for i:=1 to 10 doif a[i]=50 then n:=i;if n=0 then write ('нет') else write (i);writeln();writeln('2 прога');s:=0;//вторая прогаfor i:=1 to 10 do a[i]:=random(50);for i:=1 to 10 do write (a[i],' ');imax:=1;for i:=2 to 10 doif a[i]>imax then imax:=1;writeln();write ('наибольший элемент a[', imax, ']=' ,a[imax]);writeln();writeln('1 прога');begin//1 прогаfor i:=1 to 10 do a[i]:=random(50);for i:=1 to 10 do n:=n+a[i];writeln('Сумма елементов =',n);end;end.
0,0(0 оценок)
Ответ:
yurafenchishin
06.02.2020 10:49

Задание 1.  

Рассмотрим таблицу:

A1=3; B1=4; C1=2; D1=5

Найдем, какое значение в ячейке D2:

D2=C1+D1=2+5=7

В ячейке С2:

C2=A1+B1=3+4=7

В ячейке B2:

B2=D1-1=5-1=4

Рассмотрим диаграмму:  

На диаграмме видим два равных больших сектора(3 и 4) и два равных маленьких сектора(1 и 2).

Два равных больших сектора соответствуют ячейкам с бóльшим значением - С2 и D2.

Два равных маленьких сектора соответствуют ячейкам с ме́ньшим значением - А2 и В2, следовательно А2=В2=4

ответ: 4

Задание 2.

Рассмотрим таблицу:

A1=4; B1=2; C1=3; D1=1

Найдем значение в ячейке А2:

A2=A1-B1=4-2=2

В ячейке B2:

B2=C1-D1=3-1=2

В ячейке C2:

C2=B1-1=2-1=1

Рассмотрим диаграмму:

Сектора 1 и 2 равны, значит им соответствуют ячейки А2 и В2, т.к. А2=В2=2.

Сектор 3 меньше секторов 1 и 2, значит сектору 3 соответствует ячейка С2.

Следовательно сектору 4 соответствует ячейка D2.

Сектора 1 и 2 отделены от секторов 3 и 4 диаметром, значит сумма значений в ячейках А2 и В2 равна сумме значений в ячейках C2 и D2, тогда:

A2+B2=C2+D2

2+2=1+D2

D2=4-1=3 нужный ответ

1) D2=A1-2=4-2=2 – не подходит

2) D2=A1-1=4-1=3 – подходит

3) D2=C1+D1=3+1=4 – не подходит

4) D2=B1+D1=2+1=3 – подходит

5) D2=2*B1-D1=2*2-1=4-1=3 – подходит

ответ: 2); 4); 5).


с информатикой, девятый класс, тема - Ехеl
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота