Bzxbv
12.01.2020 22:06

Напишите программу для тех, кто не сделал это задание в классе: Напишите программу, которая вычисляет выражение, состоящее из трех чисел и двух
знаков (допускаются знаки «+», «–», «*» и «/»). Выражение вводится как символьная строка,
все числа целые. Операция «/» выполняется как целочисленное деление.
Пример:
Введите выражение:
12*3+45
ответ: 81

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tanyaanya200615
30.04.2020 22:52

Алгоритм — конечная совокупность точно заданных правил решения произвольного класса задач или набор инструкций, описывающих порядок действий исполнителя для решения некоторой задачи.

Первый тип — линейный алгоритм; такой, в котором все действия выполняются в строгом порядке, последовательно, одно за другим.

Второй тип — разветвляющийся алгоритм; такой, в котором выполняются те или иные действия в зависимости от выполнения или невыполнения не­коего условия. 

 Третий тип — циклический алгоритм; такой, в котором присутству­ют повторяющиеся действия с какой-либо изменяющейся величиной, так называемым параметром.

Компьютер - машина, выполняющая алгоритмы.

Basic, C++, Java, Python, Pascal.

Алгоритм, записанный на «понятном» компьютеру языке программирования, называется программой.

0,0(0 оценок)
Ответ:
10203040502017
30.04.2020 22:52

Алгоритмом называется точное и понятное предписаниe исполнителю совершить последовательность действий, направленных на решение поставленной задачи.При всем многообразии алгоритмов решения задач в них можно выделить три основных вида вычислительных процессов:

линейный;

ветвящийся;

циклический.

Компьютер

Python, JavaScript,C++

Пример программы на языке программирования Паскаль:

PROGRAM RR;

VAR A,B,C, max: INTEGER;

BEGIN

WRITE(‘ ВВЕДИТЕ A, B, C');

READLN(A,B,C);

IF A>B THEN max:=A

ELSE max:=B;

IF C>max THEN max:=C;

WRITELN(max);

END.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота