1941108
13.03.2021 14:23

составить программу на Паскале, когда дан массив от 1 до 10 в диапозоне -50 и +50 и сделать так ,чтобы в ответе было: 5 цифр в строчку и 2 в столбик ,сумма мин и маx, и ещё это связано каким -то образом с randomize(рандомом)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
supermosyagina
13.04.2023 14:29

Первая

Program n1;
Uses CRT;
Var a,b,c,k: integer;
begin
Writeln('Vvedite a,b,c');
Readln(a,b,c);
If (a=b)and(b=c) then begin k:=1; writeln('Ravnostoronnij') end else
If (a=b)or(b=c)or(a=c) then begin k:=1; writeln('Ravnobedrennij'); end;
If (sqr(a)=sqr(b)+sqr(c))or(sqr(b)=sqr(a)+sqr(c))or(sqr(c)=sqr(b)+sqr(a))
then begin k:=1; writeln('Pryamoygolnij'); end;
If (a>b+c)or(b>a+c)or(c>a+b) then begin k:=1; writeln('treygolnik nelza sostavit'); end;
If k=0 then writeln('Treygolnik Raznostoronnij');
readln
end.

 

 

Вторая 

Program n1;
Uses CRT;
Var a,b,c: integer;
begin
ClrScr;
Writeln('Vvedite a,b,c');
Readln(a,b,c);
If (a>0)and(b>0)and(c>0) then writeln('Summa kvadratov=',sqr(a)+sqr(b)+sqr(b));
If (a mod 2=0)or(b mod 2=0)or(c mod 2=0) then writeln('Summa =',a+b+c,', Proizvedenie =',a*b*c);
readln
end.

0,0(0 оценок)
Ответ:
timati06blacstar
28.02.2021 22:22

unit math;

var

   d,m:array[1..20] of integer;

   sr:real;

   kol,s:integer;

Begin

  for i:=1 to 20 do begin

    d[i]:=RandomRange(140,180);

    writeln('Рост ',i,'-ой девочки =',d[i],' см');

    m[i]:=RandomRange(140,190);

    writeln('Рост ',i,'-го мальчика= ',m[i],' см');

  end;

 s:=0;sr:=0;kol:=0;

 for i:=1 to 20 do s:=s+m[i];

 sr:=s/20;

 writeln('Средний рост мальчиков= ',sr,' см');

 for i:=1 to 20 do

  if d[i]>sr then kol:=kol+1;

 writeln('Колличество девочек превышающий средний рост мальчиков= ',kol);

End.

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота