Privetcsfvxs
10.07.2022 06:10

с информатикой 10 класс 1. В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 1, 12, 23, 34, 45, 56, 67, 78, 89, 90, то есть А[0]=1, А[1]=12 и т. д. Определите значение переменной S после выполнения следующего фрагмента программы:
s:=5;
n:=10;
For I:=1 to n-1 do begin
s:=s+A[i]×A[i]-A[i-1]×A[i-1];
end;

2. В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 5, 7, 2, 3, 4, 6, 5, 5, 6, 4, то есть А[0]=5, А[1]=7 и т. д. Определите значение переменной S после выполнения следующего фрагмента программы:
s:=0;
For i:=0 to 8 do begin
If A[i] < A[9] then begin
t:=A[i];
A[i]:=A[8-i];
A[8-i]:=t;
s:=s+t;
End
End

3. В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 12, 8, 15, 23, 11, 4, 9, 22, 10, 15 соответственно, то есть А[0]=12, А[1]=8 и т.д. Определите значение переменной S после выполнения следующего фрагмента программы:
s:=0;
n:=7;
for i:=0 to 9 do
If A[i] <= А[n] then begin
s:=s+A[i];
t:=A[i];
A[n]:=A[i];
A[n]:=t;
n:=i mod 3;
End
Writeln(s);

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Monimix
22.10.2020 17:58

Объяснение:

#include<iostream>

#include<math.h>

using namespace std;

Int main()

{

Double ch,min,sec,ch1,min1,sec1,ch2,min2,sec2,minut;

setlocale (LC_ALL, " rus");

cout<<"Введите время начала разговора ch1, min1, sec1 " << "\n";

cin>>ch>>min>>sec;

Cout<<"Введите врямя конца разговора ch2 ,min2, sec2 "<<"\n";

cin>> ch2>>min2>>sec2;

ch=ch2-ch1;

min=min2-min1;

sec=sec2-sec1;

min=ch*60+min+(sec/60);

minut=min*30;

Cout<<"Стоимость разговора = "<<minut<< " копеек "

return 0;

}

0,0(0 оценок)
Ответ:
hlebushek225
11.10.2022 10:03
Здесь нужно использовать вс типизированный файл и, соответственно, вторую файловую переменную (fr2).
Сделать это можно так:
while not eof(fr) and (kol=0) do
begin
read(fr, Marshrut);
if (Marshrut.NK.N <> '11')
   then write(fr2,Marshrut)
   else begin inc(kol); y:=Marshrut; end;
end;
if not eof(fr) then
  begin
  read(fr, Marshrut);
  write(fr2,Marshrut);
  end;
if (kol=1) then  write(fr2,y);
Дальше нужно просто переписать оставшиеся записи из первого файла во второй. Затем оба файла закрыть, первый файл удалить, а второй переименовать (т.е. назвать его так, как назывался первый файл).

Попробуйте ещё вот такой вариант:
(здесь k1 и k2 - целые, а y - типа )
if (Marshrut.NK.N = '11') then
begin
writeln('... ');
inc(kol);
y:=Marshrut;
k1:=FilePos(fr)-1;
k2:=FilePos(fr);
if not eof(fr) then
 begin
 read(fr, Marshrut);
 seek (fr, k1);
 write(fr, Marshrut);
 seek (fr, k2);
 write (fr, y);
 end;

end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота