olya0611
20.03.2023 16:01

Реализация разветвляющегося алгоритма с++

20. составить программу для вычисления значения выражения: max (a, bc, min(d, b))

нужен код программы выручайте)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
popova2015
18.06.2022 13:01

program zaharmaenkraft;

const n = 10;

type mas = array [1..n, 1..n] of integer;

var a: mas;

   i, j, summa1, summa2: integer;

begin

writeln('Дан двумерный массив размерностью 10 на 10. Определить:');

writeln('1) сумму элементов главной диагонали массива;');

writeln('2) среднее арифметическое элементов главной диагонали;');

writeln('3) среднее арифметическое элементов побочной диагонали.');

writeln;

writeln('Созданный массив:');

for i := 1 to n do

 for j := 1 to n do

 begin

  a[i, j] := random(201) - 100;

  write(a[i, j], '; ');

  if (j = n) then writeln;

 end;

writeln;

summa1 := 0;

summa2 := 0;

for i := 1 to n do

 for j := 1 to n do

 begin

  if (i = j) then summa1 := summa1 + a[i, j];

  if (j = n - i + 1) then summa2 := summa2 + a[i, j];

 end;

writeln('Сумма элементов главной диагонали массива равна ', summa1);

writeln('Среднее арифметическое элементов главной диагонали равно ', summa1 / n : 0 : 1);

writeln('Среднее арифметическое элементов побочной диагонали равно ', summa2 / n : 0 : 1);

readln;

end.

0,0(0 оценок)
Ответ:
stig228
17.07.2021 18:00
Паскаль
---
uses crt;
var a: array[1..100,1..100] of integer;
    x,y,sum,k,n:integer;
begin
     write('Введите n: ');
     readln(n);
     clrscr;
     for x:=1 to n do begin
         for y:=1 to n do begin
             a[x,y]:=random(21)-10;
             write(a[x,y]:4);
         end;
         writeln;
     end;
     k:=0;
     Sum:=0;
     for x:=1 to n do
         for y:=x+1 to n do
             if a[x,y]>0 then begin
                Sum:=Sum+a[x,y];
                inc(k);
             end;
     writeln;
     if k<>0 then write(sum/k:4:2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота