radkov02p08713
01.02.2022 19:48

- Очень надо! Написать программу на КуМир, с исполнителем Робот, которая в зависимости от введённого пользователем имени, слова и т.д, будет его закрашивать (слово), то есть ты ввёл имя Артём, и робот нарисовал на поле Артём

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kleira
05.05.2023 19:50

1)

Program Pr1;
uses crt;
var stroka:string;
i,k:integer;
Begin
clrscr;
writeln('Vvedite chislo');
readln(stroka);
k:=0;
for i:=length(stroka) downto 1 do if stroka[i]='3' then k:=i;
writeln(k);
end.

2)

Program Pr2;
uses crt;
var stroka:string;
i,k,x,y:integer;
Begin
clrscr;
readln(stroka);
y:=0;
for i:=length(stroka) downto (length(stroka)-1) do begin
val(stroka[i],k,x);
y:=y+k;
end;
writeln(y);
end.

 3)

Program Pr2;
uses crt;
var stroka:string;
i,y,k:integer;
mas:array[byte] of integer;
Begin
clrscr;
readln(stroka);
for i:=1 to length(stroka) do begin
val(stroka[i],y,k);
mas[i]:=y;
end;
k:=0;
for i:=1 to length(stroka) do if mas[i]>k then k:=mas[i];
writeln(k);
end.

4)

Program Pr2;
uses crt;
var stroka,tmp:string;
Begin
clrscr;
readln(stroka); {1-oe predlojenie}
readln(tmp); {2-oe predlojenie}
delete(stroka,1,length(tmp));
stroka:=tmp+stroka;
writeln(stroka);
end.

5)

Program Pr2;
uses crt;
var mas:array[byte] of integer;
i,n,f:integer;
Begin
clrscr;
readln(n);
mas[1]:=1;
mas[2]:=1;
for i:=3 to n do mas[i]:=mas[i-1]+mas[i-2];
writeln(mas[n],' a'); {a}
readln;
for i:=1 to n do write(mas[i],' '); {á}
f:=0; {â}
readln;
for i:=1 to n do f:=f+mas[i];
if f mod 2=0 then writeln('TRUE')
else writeln('FALSE');
end.

0,0(0 оценок)
Ответ:
AnnFair
05.05.2023 19:50

using System;
using System.Collections.Generic;
using System.Linq;

namespace Diagonals {
   
    class Program {
        static void Main(string[] args) {
            IsXinN();

            TwoEqualNeibors() ;

            Console.ReadKey();
        }

        public static void IsXinN() {
            Console.WriteLine("Введите N");
            string n = Console.ReadLine();
            Console.WriteLine("Введите X");
            char x = Convert.ToChar(Console.ReadLine());
            Console.WriteLine(n.ToCharArray().Contains(x));
        }

        public static void IsTwoEqualNeibors() {
            List<int> NumList = new List<int>();

            Console.WriteLine("Введите последовательность чисел");
            int n = Convert.ToInt16(Console.ReadLine());
            while (n != 0) {
                NumList.Add(n);
                n = Convert.ToInt16(Console.ReadLine());
            }

            bool EqualNeibors = false;
            for (int i = 0; i < NumList.Count - 1; i++) {
                EqualNeibors = EqualNeibors || NumList[i] == NumList[i + 1];
            }
            Console.WriteLine(EqualNeibors);
        }
    }
}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота