anton277
09.07.2021 19:57

написать программу на с++: Напишіть програму, яка визначає поведінку космічного апарата, що стартує на екваторі, залежно від його початкової швидкості v, заданої у км/с (дійсні числа). Як ви знаєте з уроків фізики, тут можливі чотири випадки: при v < 7,8 км/с апарат впаде на поверхню Землі; при 7,8 ≤ v < 11,2 км/с апарат стане супутником Землі; при 11,2 ≤ v < 16,4 км/с апарат стане супутником Сонця; при v ≥ 16,4 км/с космічний апарат покине Сонячну систему. Вхідні дані:

12.5
22.56
8.3
Вихідні дані:

The device became a satellite of the Sun.
The device left the Solar system.
The device became a satellite of the Earth.
Розділ: РОЗГАЛУЖЕННЯ | Рівень складності: ПОЧАТКОВИЙ

В університеті використовується наступна шкала для інтерпретації результатів тестування студентів: ів і вище (A), 80-89 (B), 70-79 (C), 60-69 (D), нижче 60 (F). Напишіть програму, яка дозволить студенту ввести тестовий бал, а потім відобразити оцінку для цього балу.

Вхідні дані:

95
48
74
Вихідні дані:

Your grade is A.
Your grade is F.
Your grade is C.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ilyamilovanov1
23.04.2021 01:58
Class ArrayEven{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
  while((eArray[eArray.length-1] = in.nextLong())!=-1){
   long nArray[] = new long[eArray.length+1];
   for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
   eArray = nArray;
  } eArrayCell:
  for(int cCell = 0; cCell<eArray.length-1; cCell++){
   if(eArray[cCell]%2==1)continue;
   else for(int eCell = cCell+1; eCell<eArray.length-1; eCell++)
   if(eArray[eCell]%2==1){
    eArray[eArray.length-1]=eArray[cCell];
    eArray[cCell]=eArray[eCell];
    eArray[eCell]=eArray[eArray.length-1];
    continue eArrayCell;
   }
   break;
  }
  for(int cCell = 0; cCell<eArray.length-1; cCell++)System.out.print(eArray[cCell]+" ");
 }
}
0,0(0 оценок)
Ответ:
lenakors1997
28.12.2022 19:39
Class ArrayEven{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
  while((eArray[eArray.length-1] = in.nextLong())!=-1){
   long nArray[] = new long[eArray.length+1];
   for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
   eArray = nArray;
  } eArrayCell:
  for(int cCell = 0; cCell<eArray.length-1; cCell++){
   if(eArray[cCell]%2==0)continue;
   else for(int eCell = cCell+1; eCell<eArray.length-1; eCell++)
   if(eArray[eCell]%2==0){
    eArray[eArray.length-1]=eArray[cCell];
    eArray[cCell]=eArray[eCell];
    eArray[eCell]=eArray[eArray.length-1];
    continue eArrayCell;
   }
   break;
  }
  for(int cCell = 0; cCell<eArray.length-1; cCell++)System.out.print(eArray[cCell]+" ");
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота