Напишите программу: сформулировать числовой массив А(n) , элементами которого будут целые числа от -5 до 25. Подсчитать положительные элементы массива .
1.НАЧАЛО 2.Взять чистую сковороду 3.Поставить сковороду на огонь. 4.Налить немного масла 5.Если масло разогрелось, то перейти к шагу 8 6.Подождать 2 минуты 7.Перейти к шагу 5. 8. Разбить на сковороду 3 яйца 9. Уменьшить огонь до минимума 10. Посолить яичницу 11. Накрыть сковороду крышкой (я люблю прожаренные и сверху) 12. Подождать 7 минут. 13. Снять сковороду с огня. 14. Выложить яичницу на тарелку. 15. Положить на тарелку по вкусу майонез, лук, колбасу и проч. 16. Приятного аппетита! 17. КОНЕЦ
var s,v,t,a:real; begin writeln('Введите скорость, ускорение и время соотвественно'); read(v,a,t); s:=v*t+(a*sqr(t))/2; writeln('Расстояние S = ',s); end.
Задание №2
var a,b,c,d,m,n:integer; begin writeln('Введите ширину и высоту комнаты'); read(a,b); writeln('Введите размеры окна'); read(c,d); writeln('Введите размеры двери'); read(m,n); writeln('Площадь стен для оклеивания обоями = ',a*b-c*d-m*n); end.
Задание №3
var a,b:real; begin writeln('Введите два числа'); read(a,b); writeln('Среднее арифметическое кубов этих чисел = ',(power(a,3)+power(b,3))/2); writeln('Среднее геометрическое модулей этих чисел = ',sqrt(abs(a*b))); end.
Задание №4
var x:real; begin writeln('Введите ребро куба'); read(x); writeln('Площадь грани = ',sqr(x)); writeln('Площадь полной поверхности = ',6*sqr(x)); writeln('Объем куба = ',power(x,3)); end.
Задание №5
var r1,r2:real; begin writeln('Введите внешний и внутренний радиус'); read(r1,r2); if r1<r2 then writeln('Внешний радиус должен быть больше внутреннего') else writeln('Площадь кольца = ', Pi*sqr(r1)-Pi*sqr(r2)); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку