xandias
02.07.2020 12:31

Необходимо написать программу в PascalABC, переводящую градусы по Фаренгейту в градусы по Цельсии (использовать условие - F = C * 1,8 + 32). Для переменных использовать "Real" вместо "Integer". Ниже прикреплю программу, получившуюся у меня (она, конечно, неверная). Задание оценивается в Program qq;

Uses crt;

Var F, C: Real;

Begin

Writeln ('Сколько градусов по Фаренгейту?');

Readln (F);

C:= F-32 div 2;

Writeln (',C, градусов Цельсия');

end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nika1337228
02.01.2023 17:15
Восприятие информации человеком — это ознакомление с явлениями и предметами посредством их воздействия на различные органы чувств. Анализируя результат воздействия того или иного предмета или ситуации на органы зрения, слуха, обоняния, вкуса и осязания, индивид получает определенное представление о них. Таким образом, основа в процессе восприятия информации — пять наших органов чувств. При этом активно задействованы опыт человека и ранее полученные знания. Обращаясь к ним, можно отнести полученную информацию к уже известным явлениям или выделить из общей массы в отдельную категорию восприятия информации базируются на некоторых процессах, связанных с психикой человека: - Читайте подробнее на
мышление (увидев или услышав предмет или явление, человек, начиная мыслить, осознает, с чем он столкнулся); речь (возможность назвать объект восприятия); чувства (различные виды реакций на предметы восприятия); воля человека организовывать процесс восприятия).
0,0(0 оценок)
Ответ:
SlavaArt
07.03.2021 07:55

Пиксели дисплея состоят из ЖК-молекул, выстроенных между прозрачными электродами, а также из пары поляризационных фильтров с перпендикулярными друг другу осями полярностей. В отсутствие жидкого кристалла свет, проходя через один поляризатор, блокируется другим. Поверхность электродов, контактирующих с веществом, находящимся в ЖК-фазе, обработана так, чтобы молекулы выстраивались в определенном направлении. Как правило, они покрываются тонким слоем полимера, направленного в одну сторону методом протирания его тканью (жидкие кристаллы выстраиваются в том же направлении). Принцип работы ЖК-монитора следующий. До наложения электрического поля ЖК-молекулы выстроены согласно направлению выравнивания поверхностей. В наиболее рас типе ЖК-экрана – крученном нематическом – направления выстраивания поверхностей электродов перпендикулярны, благодаря чему молекулы образуют спиралевидную структуру, т. е. скручиваются. Так как свойством жидких кристаллов является разная скорость движения света с разной поляризацией, луч, который проходит через один поляризационный фильтр, вращается ЖК-спиралью так, что может пройти сквозь второй. При этом половина света поглощается в первом поляризаторе, но в остальном вся сборка прозрачна. Когда на электроды подается напряжение, начинает действовать крутящий момент, который выравнивает молекулы скрученного нематического кристалла вдоль электрического поля и выпрямляет спиралевидную структуру. Этому препятствуют упругие силы, так как молекулы на поверхностях не свободны. Вращение поляризации уменьшается, и пиксель выглядит серым. Но благодаря свойству жидких кристаллов выравниваться при достаточно высокой разности потенциалов, проходящий сквозь них свет не вращается. В результате направление поляризации становится перпендикулярным второму фильтру, он полностью блокируется, и пиксель выглядит черным. Изменение напряжения между электродами по обе стороны ЖК-слоя каждого элемента изображения регулирует количество проходящего света и, соответственно, его яркость. Скрученные нематические жидкие кристаллы помещаются между скрещенными поляризационными фильтрами для того, чтобы свет был максимально ярким без расхода электроэнергии, а получаемое при подаче напряжения затемнение - являлось равномерным. Возможен случай использования параллельных поляризационных фильтров. При этом темные и яркие состояния изменяются на противоположные. Однако в такой конфигурации черный не будет равномерным. Вещество жидкого кристалла и выравнивающий слой содержат ионные соединения. Если длительное время действует электрическое поле определенной полярности, ионный материал притягивается поверхностями, ухудшая характеристики ЖК-монитора. Избежать этого можно, применяя либо переменный ток, либо изменяя полярность электрического поля во время обращения к устройству (реакция ЖК-слоя не зависит от полярности). - Читайте подробнее на FB.ru: https://fb.ru/article/382111/jk-monitoryi-printsip-rabotyi-ustroystvo-osobennosti-uhoda-diagnostika-remont-preimuschestva-i-nedostatki

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота