маркинала
01.04.2022 13:24

написать программу на C# Заполнить массив из десяти элементов значениями, вводимыми с клавиатуры
в ходе выполнения программы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sofiakobzeva
06.06.2022 22:09
Предположим, что фальшивая монета легче подлинной.
Разделим монеты на группы по 15 и одну монету отложим в сторону. Взвесим группы по 15. Если весы находятся в равновесии, то фальшивая монета отложена. Если же одна из чаш весов оказалась легче, то фальшивая монета там.
15 монет из легкой чаши снова разделим на 7, 7 и монета в стороне. Повторим взвешивание. Если фальшивая монета не найлена, то из более легкой чаши монетки разделим на 3, 3 и одну.
Повторим взвешивание с лекгой чашей  в четвертый раз. 1, 1 и монета в стороне. 
Фальшивка найдена не более чем за 4 взвешивания.
0,0(0 оценок)
Ответ:
yuri520
14.12.2021 19:37

Возрастание:

const n=10;

var a:array [1..n] of integer;

i,j,v:integer;

begin

write('       Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(90)+10;

write(a[i],'  ')

end;

writeln;

for i:=1 to n do

for j:=1 to n-i do

if a[j]>a[j+1] then

begin

v:=a[j];

a[j]:=a[j+1];

a[j+1]:=v

end;

write('Отсортированный массив: ');

for i:=1 to n do write(a[i],'  ');

end.

Убывание:

const n=10;

var a:array [1..n] of integer;

i,j,v:integer;

begin

write('       Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(90)+10;

write(a[i],'  ')

end;

writeln;

for i:=1 to n do

for j:=1 to n-i do

if a[j]<a[j+1] then

begin

v:=a[j];

a[j]:=a[j+1];

a[j+1]:=v

end;

write('Отсортированный массив: ');

for i:=1 to n do write(a[i],'  ');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота