Gladiator974
15.11.2021 10:14

СОЧ ПО ИНФОРМАТИКЕ 8 КЛАСС 1. Дополните предложение.

Системы программирования - ……

Языки программирования - ……

2. Даны переменные.

A=’ A’ B=456 C=123.4 D=True

Определите типы данных для каждой переменной и соедините линиями тип

данных и

переменную.

3. Задача «Максимум из трех чисел»

Условие

Введите с клавиатуры три целых числа. Выведите значение наибольшего из

них.

4. Задача «Hello, User!»

Loop

Напишите программу бесконечного цикла, которая просит имя пользователя

и приветствует его, выводя слово Hello, введенное имя и знаки препинания

по образцу:

Введите имя: Джон

Привет, Джон!

Введите имя: Гарри

Привет, Гарри!

Цикл должен остановиться, когда пользователь введет «Хватит»

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sailorproblema
21.02.2022 21:47
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
  var k:=0;
  var n:=ReadInteger();
  var nmax:=0;
  while n<>0 do begin
    Inc(k);
    if n mod 10 = 0 then
      if n>nmax then nmax:=n;
    n:=ReadInteger()  
    end;
  var cntrl:=ReadInteger();
  Writeln('Получено ',k,' чисел');
  Writeln('Полученное контрольное значение: ',cntrl);
  Writeln('Вычисленное контрольное значение: ',nmax);
  if cntrl=nmax then Writeln('Контроль пройден')
  else Writeln('Контроль не пройден')
end.

Тестовое решение:
53
16
40
9
10
32
74
0
40
Получено 7 чисел
Полученное контрольное значение: 40
Вычисленное контрольное значение: 40
Контроль пройден
0,0(0 оценок)
Ответ:
Rezars19
10.08.2021 22:39
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота