SaraTyan
14.01.2022 22:03

Python Определите и запишите РЕЗУЛЬТАТ выполнения программы составленной к

задаче, при Z=98, x=25 и y=46. *

У Царевны-лягушки собралось z любовных посланий, из них х посланий на

бумаге, у посланий на бересте, а остальные на стрелах. Составьте программу,

находящую, сколько посланий на стрелах собрала Царевна-лягушка.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kristina761
19.09.2020 22:08

1.

1) s := (x1+x2)/2

2) dec(k) или k:=k-1

3) inc(i) или i:=i+1

4) sum := t*kt + r*kr + k*kk (t, r, k - цена одной тетради, ручки, карандаша;  kt, kr, kk - количество тетрадей, ручек и карандашей) 

 

2.

а) значения функции y=х(в квадрате)

var y,x: real

 

б) площади прямоугольника

var a,b,s: real

 

в)стоимости покупки,состоящей из нескольких тетрадей и такого же кол-ва обложек

var kv:integer; st,so,sum: real

 

г)стоимости покупки,состоящей из нескольких тетрадей,нескольких ручек и нескольких карандашей

var kvt,kvr,kvk:integer; st,sr,sk,sum: real

0,0(0 оценок)
Ответ:
NastiLife
26.09.2020 12:21
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Кол-во элементов:');
  var a:=ArrRandomReal(n,-10,20); a.Println;
  Writeln('С округлением если |x|<1');
  for var i:=0 to n-1 do
    if abs(a[i])<1 then a[i]:=Round(a[i]);
  a.Println
end.

Тестовое решение:
Кол-во элементов: 10
-0.751956142835299 5.95022566427953 3.58861613254464 7.42331713783709 -4.75036238075717 -9.41228387384316 -0.700975591643235 3.85500546258642 -1.94321916994789 19.3021338336645
С округлением если |x|<1
-1 5.95022566427953 3.58861613254464 7.42331713783709 -4.75036238075717 -9.41228387384316 -1 3.85500546258642 -1.94321916994789 19.3021338336645
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота