NarkoBaronTif
02.08.2022 11:41

Напишите программу. Числа Фибоначчи (fn) определяются формулами f0=f1=1; fn=fn-1+fn-2 при n=1,2..., тоесть это бесконечная последовательность чисел вида: 1,1,2,3,5,8,13,21,34,55,89,...Определите номер последнего числа Фибаначчи , который входит в диапазон от 1 до 2^16

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
JamesBond007007007
14.04.2021 20:17

var

 v, c, a, b, n,count: integer;

begin

 write('Введите максимальное число N = '); readln(n);  

 a := 0; b := 1;

 count:=1;

 repeat

   c := b;

   b := a + b;

   a := c;

   v := a + v;

   inc(count);

 until v-a>n;

 writeln(count,': ',a);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота