Aydan204
06.11.2022 12:00

Напишите программу, в которой вводится число. Требуется вывести его так, что бы составляющие его цифры шли в обратном порядке. Например, вводится число 4096, надо вывести 6904. (Примичание: используйте условие внутри тела цикла, mod и div)

На вход: 123 7354
На выход 321 4537 ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ilya333444
09.12.2021 21:23
Чтобы излишне не терять точность и не тратить лишнее время на вычисления, выведем рекуррентную формулу.
\displaystyle a_1= \frac{3}{2}; \\ \\ a_{i-1}=\frac{3^{i-1}\cdot (i-1)!}{[2(i-1)]!}; \\ \\ a_i=\frac{3^i\cdot i!}{(2i)!} = \frac{3\cdot3^{i-1}\cdot i\cdot(i-1)!}{2 i\cdot(2i-1)\cdot(2i)!}={ \frac{3i}{2i\cdot(2i-1)}\cdot a_{i-1}=\frac{3}{4i-2}\cdot a_{i-1}
В задании не сказано точно, как определять условие окончания суммирования. Примем, что суммирование завершается, если очередной член ряда не может изменить накопленную сумму больше, чем на ε, т.е.
|aₓ| ≤ ε.

// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (ai1,eps,s,i):=(3/2,0.001,3/2,2);
  while true do begin
    var a:=3/(4*i-2)*ai1;
    if Abs(a)>eps then begin i+=1; s+=a; ai1:=a end
    else Break
    end;
  Writeln('S = ',s:0:3)
end.

Результат
S = 2.532

Напишите программу для суммы числового ряда. дан числовой ряд и малая величина е(эпсила). найдите су
0,0(0 оценок)
Ответ:
roma1918
22.08.2022 18:01
◘Объективность информации. Например: "На улице холодно" - это субъективная информация. А "На улице -14°" - объективная (но не всегда точная)
◘Достоверность информации. Ин-фа достоверна, если отражает истинное положение дел. (объективная информация всегда достоверна)
◘Полнота информации. Информация полная, если ее достаточно для понимания и принятия решения.
◘Точность информации. Определяется степенью ее близости к реальному состоянию объекта, процесса, явления и т.д.
◘Актуальность информации – важность для настоящего времени.
◘Полезность информации.
 - Самая ценная информация – объективная, достоверная, полная, и актуальная.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота