aramdarbinyan
21.05.2023 08:35

Как написать программу на c++, чтобы в цикле 1000-7-7-7-7 и тд

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Galinachlen
20.04.2021 23:05
Решение для одного-двух разных удаляемых символов

// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Replace('.','').Replace(',','');
  s.Println
end.

Пример
> Раз, два, три, четыре, пять. Вышел зайчик погулять.
Раз два три четыре пять Вышел зайчик погулять

Решение, когда разных удаляемых символов может быть много

// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Where(с->not(с in [',','.'])).JoinIntoString;
  s.Println
end.
0,0(0 оценок)
Ответ:
alalosh
05.05.2022 12:08

Ну вот так это будет выглядеть с ветвлением и возможностью повторять вычисления без повторного запуска программы.

var a,b,c,d,z:integer;

begin
writeln('Введите 1 число');
read(a);
writeln('Введите 2 число');
read (b);
writeln('Введите 3 число');
read (c);
d:=a+b+c;
writeln('Сумма чисел ',a,'+',b,'+',c,'=',d);
writeln ('Хотите ли вы решить еще один пример? 1-ДА, 0-Нет');
read (z);
while (z = 1) do
begin
writeln('Введите 1 число');
read(a);
writeln('Введите 2 число');
read (b);
writeln('Введите 3 число');
read (c);
d:=a+b+c;
writeln('Сумма чисел ',a,'+',b,'+',c,'=',d);
writeln ('Хотите ли вы решить еще один пример? 1-ДА, 0-Нет');
read (z);
end;

end. 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота