555766
24.11.2020 22:05

Напишите программу на языке программирования Python для решения следующих задач:
​


Напишите программу на языке программирования Python для решения следующих задач: ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
57494967468746
21.03.2023 03:19

Будет нарисовано что то типа заглавной буквы "Д" но только у неё правая нижняя палочка не оттуда растёт немного.

Подробнее- смотри скрин внизу (жирная линия на скрине- это так отображается рисующее перо Чертёжника, его в принципе можно увести в другое место в конце алгоритма, чтобы оно там не мешалось, только предварительно подняв перо).

Вот ваша программа (в полном нормальном виде для системы Кумир, без кучи всяких мелких ошибок типа точки вместо запятой и больших букв там где не надо):

использовать Чертежник

алг

нач

сместиться в точку (1,1)

опустить перо

сместиться в точку (1,2)

сместиться в точку (5,2)

поднять перо

сместиться в точку (5,1)

опустить перо

сместиться в точку (4,2)

сместиться в точку (4,5)

сместиться в точку (3,5)

сместиться в точку (2,4)

сместиться в точку (2,2)

кон

А вот я поправил программу, чтобы она рисовала правильную букву "Д",  и ещё после уводила перо в сторону, чтобы оно не мешало смотреть рисунок. Результат работы этой программы- смотри на втором скрине.

использовать Чертежник

алг

нач

сместиться в точку (1,1)

опустить перо

сместиться в точку (1,2)

сместиться в точку (5,2)

сместиться в точку (5,1)

поднять перо

сместиться в точку (4,2)

опустить перо

сместиться в точку (4,5)

сместиться в точку (3,5)

сместиться в точку (2,4)

сместиться в точку (2,2)

поднять перо

сместиться в точку (7,2)

кон


Что будет нарисовано после выполнения Чертежником алгоритма?Стартовая позиция Чертежника (0,0).Смест
Что будет нарисовано после выполнения Чертежником алгоритма?Стартовая позиция Чертежника (0,0).Смест
0,0(0 оценок)
Ответ:
Ashmalikova
02.05.2020 19:16
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var a:=ArrRandom(100,-10,10);
  a.Println;
  Writeln(a.Where(x->x>0).Count,' положительных, ',
    a.Where(x->x<0).Count,' отрицательных')
end.

Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота