анаркааа54
17.02.2023 09:46

С++ На вход программе подается последовательность из N чисел от 0 до 9. Подсчитайте в этой последовательности количество нулей, единиц, двоек, троек и т.д. В выходных данных всегда должно быть 10 чисел.

Формат входных данных
В первой строке входных данных вводится натуральное число N, не превосходящее 10000 - количество чисел.

В следующей строке вводятся N целых чисел от 0 до 9 через пробел.

Формат выходных данных
10 целых чисел через пробел - количество нулей, единиц, двоек и т.д.
входные данные
18
4 2 6 3 3 8 0 3 6 5 8 9 5 8 5 8 1 2
выходные данные
1 1 2 3 1 3 2 0 4 1

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dimass56789
16.12.2021 08:24

Автомобиль: двигатель, ходовая часть, трансмиссия, электрооборудование.

Школа: руководство, персонал, ученики, учителя, деление на классы.

Армия: главнокомандующие, различные виды войск, рядовые.

Государство: власть, политические партии, народ.

Компьютер: системный блок, оперативная память, центральный процессор, регистры.

2) Возьмем за пример

Водонагреватель. Служит для подогрева проходящей через него воды.

Входы: электропитание, холодная вода.

Выходы: горячая вода.

2. Телевизор. Устройство для демонстрации изображения со звуковым сопровождением.

Входы: электропитание, сигналы от внешних устройств, управление от пульта.

Выходы: звук изображение, сигналы на внешние устройства.

Объяснение:

0,0(0 оценок)
Ответ:
mashadadihf
05.10.2020 17:22

using System;

using System.Collections.Generic;

using System.Linq;

namespace restless

{

   class Program

   {

       static void Main()

       {

           //элементы вводятся в 1 строку

           List<int> lst = new List<int>(Console.ReadLine().Split(' ').Select(x => int.Parse(x)).ToArray());

           for (int i = 0; i < lst.Count; i++)

               if (lst[i] % 2 != 0)

                   lst.RemoveAt(i);

           

           for (int i = 0; i < lst.Count; i++)

               Console.Write($"{lst[i]} ");

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота