Sestare852
24.10.2021 16:32

написать программу на питоне. На доске стоит белая шашка. Требуется определить, может ли она попасть в заданную клетку, делая ходы по правилам (не превращаясь в дамку). Назад шашка ходить не может.
Ввод - две клетки вида а1 c2 ( 4 цифры, как координаты), они гарантированно не совпадают

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dia651
07.08.2022 10:57
1)
Var
n,m,max,min:integer;
Begin
write('Введите число: ');
readln(n);
min:=9;   
max:=0;
while n>0 do 
begin 
m:=n mod 10; 
if m<min then min:=m; 
if m>max then max:=m; 
n:=n div 10; end;   
writeln('Максимальное число: ',max);   
writeln('Минимальное число: ',min);
End.
2)
var
i,count: integer;
n,s:string;
begin
writeln('Введите число: ');
readln(s);
writeln('Введите цифру: ');
readln(n);
for i:=1 to length(s) do
if(s[i]=n)then
count:=count+1;
writeln('Количество раз, когда встречается цифра = ',count);
end.
0,0(0 оценок)
Ответ:
смпанк2004
15.02.2020 14:13

розгалуження виконується, коли виконання попереднього розгалуження ще не закінчено.

Наприклад, вам потрібно встановити будильник на завтра. Якщо

завтра робочий день, то ви повинні встати о 7-й годині ранку, щоб іти

до школи. Якщо завтра субота, то ви повинні встати о 8-й годині ранку, щоб їхати на заняття гуртка. Якщо завтра неділя, то ви встаєте о

9-й годині ранку.

У наведеному на малюнку алгоритмі друге розгалуження з

умовою Завтра субота? міститься всередині першого розгалуження з

умовою Завтра робочий день?.

Такий фрагмент алгоритму називають вкладеним розгалуженням.

Вкладені розгалуження - це фрагмент алгоритму, у якому одне

розгалуження міститься всередині іншого розгалуження.

Розглянемо виконання наведеного на малюнку 3.26 фрагмента алгоритму. Спочатку перевіряється умова Завтра робочий день?. Якщо

результат перевірки цієї умови Так, то виконується команда Установити будильник на 7-му годину ранку і на цьому виконання всього

цього фрагмента алгоритму закінчується. Якщо результат перевірки

умови Завтра робочий день? - Ні, то перевіряється умова Завтра субота?. Якщо результат перевірки цієї умови Так, то виконується команда

Установити будильник на 8-му годину ранку і на цьому виконання всього цього фрагмента алгоритму закінчується, а якщо результат перевірки

цієї умови Ні, то виконується команда Установити будильник на 9-ту

годину ранку і виконання всього цього фрагмента алгоритму закінчується.

У наведеному на малюнку

фрагменті алгоритму внутрішнє

розгалуження виконується, якщо результат перевірки умови зовнішнього розгалуження Ні.

Объяснение:

рисунок 3.26 (во вложении)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота