gagikgrigoryan
24.01.2023 01:04

Информатика, 8 класс, питон Ввести натуральное число и определить, верно ли, что в его записи есть две

одинаковые цифры (не обязательно стоящие рядом).

Пример входных данных :

В первой строке входных данных –число N (0
Пример выходных данных :

Cтрока содержащая ответ – “YES”, если есть две одинаковые цифры, “NO” – если нет.

Пример :

12342 - YES

12345 - NO

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dashademidkinaozz914
06.01.2023 19:54

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{  

   int N;

   cin >> N;

   vector<int>chet;

   vector<int>nechet;

   for (int i = 0; i < N; i++) {

       int A;

       cin >> A;

       if (i % 2 == 0)

           nechet.push_back(A);

       else

           chet.push_back(A);

   }

   for (int i = 0; i < chet.size(); i++)

       cout << chet[i] << " ";

   cout << endl;

  for (int i = 0; i < nechet.size(); i++)

      cout << nechet[i] << " ";

}

0,0(0 оценок)
Ответ:
obuhovasveta
15.08.2021 00:51
#include <stdio.h>
#include <math.h>

int main(){
    const float a=2.5, b=0.4;
    float t,w;
    for(t=-1.0;t<1.0;t+=0.2){
        if (t<0.1)
            w=a*t*t+b*sin(t)+1;
        else if (t==0.1)
            w=a*t+b;
        else
            w=sqrt(a*t*t+b*cos(t)+1);
        printf("t=%f, w=%f\n",t,w);
    }
    return 0;
}
Результат выполнения программы:
t=-1.000000, w=3.163412
t=-0.800000, w=2.313058
t=-0.600000, w=1.674143
t=-0.400000, w=1.244233
t=-0.200000, w=1.020532
t=-0.000000, w=1.000000
t=0.200000, w=1.221485
t=0.400000, w=1.329821
t=0.600000, w=1.493363
t=0.800000, w=1.696668
t=1.000000, w=1.927724


Process exited after 0.08651 seconds with return value 0
Для продолжения нажмите любую клавишу . . .
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота