justlikekatya
11.12.2022 23:25

Составьте программу для вычисления произведения целых чисел, их среднее арифметическое до тех пор пока не будет введён 0 используя цикл repeat

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
хлюпхлюпик
06.10.2020 11:05
 Var
   A,S,P:real;
   k:integer;
Begin
S:=0;
P:=1;
k:=-1;
Repeat
Read(A);
if A <> 0 then P:=P*A;
S:=S+A;
k:=k+1;
Until A = 0;
WriteLn('P = ',P);
WriteLn('Sr = ',S/k);
ReadLn
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота