SashaChif
07.08.2021 12:39

Задача 4. Составить программу для определения следующих выражений S=1005*905*805*…*105 ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SoFiA5454555
25.04.2020 01:53
Сначала надо избавиться от ошибок (пункт №3)
иначе не сможем выполнить 1 и 2 пункт задания.
  Исправляем if N mod 10 k:=N mod 10; на if (N mod 10 < k) then k:=N mod 10;
  Исправляем N:N div 10; на N:= N div 10;
 
После исправления ошибок при вводе 537 получим 3
Программа будет работать правильно для любого числа,
у которого вторая цифра слева меньше первой цифры, например:
7193

Чтобы программа работала правильно для всех чисел надо
изменить это: while N > 10 do на while N > 0 do

После всех исправлений код программы стал таким:
var
  N, k: integer;
begin
  readln(N);
  k := 9;
  while N > 10 do
  begin
    if (N mod 10 < k) then k := N mod 10;
    N := N div 10;
  end;
  write(k)
end.
0,0(0 оценок)
Ответ:
Dianochkach
01.06.2022 03:04

Текстовый редактор предназначен именно для редактирования текста, четкого выставления знаков, например написания кода программ, просмотра файлов данных и т.п. Например заменить русской "у" латинское "y" будет считаться ошибкой

Текстовый процессор предназначен для создания и редактирования документов которые не предназначены для чтенья компьютером, но человеком. Когда внешний вид важнее реально содержащихся знаков ( допустимо заменить русской "у" латинское "y"). Так же там есть форматирование (шрифт, размер..), вставка обьектов типа рисунков и прочее внешнее оформление

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота