STAS228917654321
30.10.2020 00:03

ПИТОН 3 Напишите программу, которая запрашивает три пятиразрядных числа, вырезает из каждого средние три цифры и выводит их в виде чисел без ведущих нулей.

Sample Input 1:

12345 34567 56789
Sample Output 1:

234 456 678
Sample Input 2:

10062 50908 70001
Sample Output 2:

6 90 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
котикkatya
01.10.2021 08:46
Правильно пишется шестнадцатеричный. 
При переводе 2⇒16 число справа налево делится на группы из 4 цифр каждая, затем каждая группа заменяется на шестнадцатеричную цифру:
1000111111₂ = 10 0011 1111₂ = 23F₁₆
При переводе 10⇒12 число надо делить на 12 и выписать остатки от деления в обратном порядке. Остаток 10 заменить на A, остаток 11 - на B
923₁₀ = 64B₁₂
Два последних примера лучше делать за 2 действия: сначала перевести в 10-ю систему счисления, а потом - в 5 (или 12)
79₁₆ = 121₁₀ = 441₅
1050₈ = 552₁₀ = 3A0₁₂
0,0(0 оценок)
Ответ:
оля20121
10.04.2020 06:42
Const
  n=4;
var
  arr: array[1..n, 1..n] of integer;
  i, j, t, buf: integer;
begin
  for i:=1 to n do
    for j:=1 to n do
      begin
        write('Введите элемент: ');
        readln(arr[i,j]);
      end;
    writeln('Введеная матрица:');
  for i:=1 to n do
    begin
      for j:=1 to n do
          write(arr[i,j]:4);
      writeln();
    end;
//Сортировка
  for j:=1 to n do
    for i:=1 to n-1 do
      for t:=i+1 to n do
        if arr[i,j] > arr[t,j] then
          begin
            buf := arr[i,j];
            arr[i,j] := arr[t,j];
            arr[t,j] := buf;
           end;
  writeln('Отсортированная матрица:');
   for i:=1 to n do
      begin
        for j:=1 to n do
          write(arr[i,j]:4);
        writeln();
      end;
  end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота