pilipenkorita3
24.03.2020 19:40

написать программу на C++! Строка символов. Реализовать операции:
сравнение строк (операция = =);
удаления из строки указанного символа (операция -);
переворота строки (операция ~).
Кроме того, членом класса сделать также функцию с именем strset() для
удаления из первой строки всех символов, встречающихся во второй строке.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
польска
11.06.2022 19:04

Объяснение:

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "RUSSIAN");

const int n = 5;             // (1≤N≤1000)

int mass[n] = { 5, 4, 3, 2, 1 };

int k = 0;

cout << "Исходный массив: ";

for (int i = 0; i < n; ++i)

{

 cout << mass[i] << " ";

}

cout << endl;

for (int i = 1; i < n; i++) {

 for (int j = 0; j < n-1; j++) {

  if (mass[j] > mass[j + 1]) {

   int b = mass[j]; // создали дополнительную переменную

   mass[j] = mass[j + 1]; // меняем местами

   mass[j + 1] = b; // значения элементов

   k++;

  }

 }

}

cout << "Отсортированный массив: ";

for (int i = 0; i < n; ++i)

{

 cout << mass[i] << " ";

}  

cout << endl << "Kоличество обменов: " << k << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Ответ:
тоня119
11.06.2022 19:04

Объяснение:

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "RUSSIAN");

const int n = 5;             // (1≤N≤1000)

int mass[n] = { 5, 4, 3, 2, 1 };

int k = 0;

cout << "Исходный массив: ";

for (int i = 0; i < n; ++i)

{

 cout << mass[i] << " ";

}

cout << endl;

for (int i = 1; i < n; i++) {

 for (int j = 0; j < n-1; j++) {

  if (mass[j] > mass[j + 1]) {

   int b = mass[j]; // создали дополнительную переменную

   mass[j] = mass[j + 1]; // меняем местами

   mass[j + 1] = b; // значения элементов

   k++;

  }

 }

}

cout << "Отсортированный массив: ";

for (int i = 0; i < n; ++i)

{

 cout << mass[i] << " ";

}  

cout << endl << "Kоличество обменов: " << k << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота