мммм1984
03.06.2023 22:13

На вход программе подаётся последовательность из N положительных целых чисел. Сначала вводится число N, а затем все остальные числа. Программа должна нати среднее арифметическое тех чисел, которые делятся на 3 и последняя цифра которых при том равна 7.​ (язык паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
albina1002
22.01.2021 04:51
#include <iostream>#include <cstdlib>using namespace std;
int main(){
int *enter = new int;
cout << "Enter x: "; cin >> *enter; const int *x = new int(*enter); *enter = 0; cout << "Enter y: "; cin >> *enter; const int *y = new int(*enter);
int *mat = new int[*x][*y];
for (int i = 0; i < *x; i++){ for (int j = 0; j < *y; j++){ cout << "Enter [" << i << "][" << j << "]: "; cin >> mat[i][j]; }; };
int *max = new int(0);
for (int i = 0; i < *x; i++){ if (mat[*x] > *max){ *max = mat[*x]; }; };}
0,0(0 оценок)
Ответ:
kirilos2014
30.01.2022 12:25
Программное обеспечение (ПО) - совокупность специальных программ, облегчающих процесс подготовки задач к выполнению на ЭВМ и организующих прохождение через машину, а также процедур, описаний, инструкций и правил вместе со связанной с этими компонентами документацией, используемых при эксплуатации вычислительной системы.
Именно программы обрабатывают информацию и управляют работой компьютера, а не устройства.
Назначение (роль) ПО:
Обеспечение работо ПК;
Облегчение взаимодействия пользовался с ПК;
Сокращение цикла от постановки задач до получения результата;
Повышение эффективности использования ресурсов ПК.
ПО позволяет:
Усовершенствовать организацию работы вычислительной системы с целью максимального использования ее возможностей;
Повысить производительность и качество труда пользователя;
Адаптировать программы пользователя к ресурсам конкретной вычислительной системы;
Расширить ПО вычислительно системы.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота