nastyabel72
18.10.2020 13:53

На Питоне ! Напишите программу, которая будет считать суммы положительных и отрицательных чисел отдельно.

Пользователь будет вводить число, а программа будет проверять: если число больше нуля, то программа добавляет его к сумме положительных. Иначе, добавляет к сумме отрицательных.

Всего программа будет проверять 5 чисел, а после этого выводить два числа: сумму всех положительных чисел и сумму всех отрицательных.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nelli37
26.05.2021 20:20

s1 = 0

s2 = 0

for i in range(5):

   a = int(input())

   if a < 0:

       s1 = s1 + a

   elif a > 0:

       s2 = s2 + a

print(s1, s2)

Не забудь проставить табуляцию, знания любят пробелы съедать.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота